Sometimes layers won't display correctly. GPU maybe?

Community Beginner ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

Hi, all. 

 

The above happens now and then. I'll create a new layer (i.e. fill with 50% grey, set to Overlay) but the display will only show the gray and not the correct blending mode. Usually, happens when Photoshop has been running a while and/or have multiple docs open or even a duplicate view of the same file. Can my GPU not handle driving my two monitors (settings attached)? Do I need to allocate more RAM? Is this software related? Thanks!

 

Photoshop 23.4.1, Windows 10, 

AMD Ryzen 5 5600G with Radeon Graphics 3.90 GHz<br />ASUS ROG STRIX B450-F GAMING II AM4 AMD B450 Motherboard<br />32GB DDR4 3600 RAM<br />NVIDIA GeForce GTX 1080<br />EIZO ColorEdge CG275W<br />EIZO ColorEdge CG277<br />Windows 10 Pro>--<br />AMD Ryzen 5 5600G with Radeon Graphics 3.90 GHz<br />ASUS ROG STRIX B450-F GAMING II AM4 AMD B450 Motherboard<br />32GB DDR4 3600 RAM<br />NVIDIA GeForce GTX 1080<br />EIZO ColorEdge CG275W<br />EIZO ColorEdge CG277<br />Windows 10 Pro
TOPICS
Windows

Views

45

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

Hi,

have you checked if there are any driver updates available for your graphics card?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

LATEST

First, try disabling GPU in the Preferences (Performance tab). Any better?
You can try this too: in Preferences>Technology Previews, check the box 'Deactivate Native Canvas' and uncheck 'Enable Native Canvas Rulers' options, then restart Photoshop. Does this work?
If not, recalibrate and build a new ICC display profile, the old one might be corrupted.
If you are using software/hardware for this task, be sure the software is set to build a matrix not LUT profile, Version 2 not Version 4 profile.

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if this is the latest OS version, you may need to roll back a release.
Also see: https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines