Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Spot healing brush behavior

Community Beginner ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

I have an issue with the spot healing brush. I'm trying to brush a few spots. So I added a new blank layer and check sample all layers. When I brush I see a grey brush stroke and that brush stroke stays visible. Only when I make the new kayer invisible and then visible again the grey brush stroke is no longer visible and I can see the result of my spot healing brush strokes. That's quite different behavior than the previous version of photoshop.

TOPICS
macOS

Views

86

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

Hi there,

Sorry to hear about this. Could you please let us know the version of Photoshop and the operating system version you're working with?

Have you tried resetting the preferences of Photoshop and see if that helps? 

https://helpx.adobe.com/photoshop/using/preferences.html

 

Note: Make sure that you back up all your custom presets, brushes & actions before restoring Photoshop's preferences. https://helpx.adobe.com/photoshop/using/preset-migration.html

 

Regards,

Sahil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

I am using Photoshop 22.5.0  Release on MacOS 10.15.7 Catalina on a iMac 8-Core Intel Core i& with 128 GB of memory. I have not tried resetting the preferences yet, because I am using the factory defaults. I only added Topaz DeNoise AI.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

Sometimes preferences go corrupt and can cause problems. So it doesn't matter that you were using the default prefs. Try deleting prefs and see if that fixes the issue.


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

I backed up the preferences and reset the preferences and that seems to help. Now I have to find out which of the prefernecs is the culprit. Anyway thanks a lot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

It might not be a specific preference. The preference file may just have got corrupt (by no fault of your own). Not sure why that makes Adobe apps glitch out, but it does. 


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

It it solved but it brings back another problem I had before. I had this problem: https://community.adobe.com/t5/photoshop-ecosystem/p-artifacts-behind-the-canvas-in-photoshop-22-5/t... and used the solution mentioned in the answer. This solution seems to cause my spot healing brush problem. When I uncheck the "Deactivate Native Canvas" the I don't have the spot healing brush problem but then I get the "Artifacts problem". For now I can live with the artifacts problem, at least I have a normal working spot healing brush. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

The problem is not really solved, see my post of Aug 27. It is either this problem of the problem described in my post of Aug 27. So I have to choose between the healing brush problem of the artifacts problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

LATEST

With the latest Photoshop update 22.5.1 both problems seem to be solved:-)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines