Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Text is not showing up in Photoshop CC 2017

Community Beginner ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

My text is not showing unless I use the move tool and resize the text. I have changed my font size to a size that should be visible, 40 pts, and the font is a bold font. But when I type, the brackets don't even move to add the type. I have to go to the move tool and drag the brackets to see the type. I have tried restarting my Photoshop and the same thing happens. I have tried using a different font and size and the same thing happens. I don't know what I am doing wrong or if I have inadvertently clicked something to make this happen. Please help and tell me what to do to fix this! I need my text!!!!

TOPICS
Problem or error

Views

51.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Jun 12, 2018 Jun 12, 2018
I found a different solution for a similar problem:Faux Bold was turned ON in the Characters panel and some fonts refuse to render at all with that option. They just disappear.Turn that off and voilà! I hope I just saved a few hairs of others in similar misery.

Likes

Translate

Translate
Community Beginner ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

This might be because you DRAG to create a text box instead of clicking. if you just click it should extend while you type. but if you drag it will vanish unless you either do as you said, and make it bigger or change the font size.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Go to the Character panel and ensure you have a different color text to your background color, that the size is large enough to see and the leading is proportional to the type size.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

I do have black on a transparent background and the size is 40 pts on a 530 x 800 pixels background so it should be plenty big enough to be visible. I've even changed it to 72 pts to try to see it and the text box still wont move. I have to drag it with the move tool to see the text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

And thank you so much for the Lynda.com recommendation! I've been nonstop on there since you told me about it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

What is the leading?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

It was set at .72 so I changed it to 40 and it didn't help anything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

And you're definitely using the Horizontal Type Tool (not one of the other Type tools?).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Also double check in Photoshop Preferences under Units & Rulers that Units – Type is Points.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Sorry I vanished... I had to go take my son some paperwork at school that he forgot. I don't know what was wrong with that image, but I deleted that image and started over and my text worked just fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2017 Mar 13, 2017

Copy link to clipboard

Copied

I had the exact same problem and I figured it out after a great deal of hair-pulling.

Some images from the web, or those that were originally stored in other formats, are missing the image metadata, including the number of pixels per inch. Photoshop then uses the default value of 1 pixel per inch, meaning that a low-resolution 420 x 360 image is (in Photoshop's mind) 35 feet wide and 30 feet tall.

There are 72 points in an inch, meaning that a 72-point font on this same image will be a whopping one pixel in height (1 pixel per inch, remember), and appear as a thin broken line, if you can see it at all.

Luckily the fix for this is easy. You just need to restore the metadata by exporting the raw image to a new jpeg.

Go to file -> export -> export as.

When the image loads, select jpeg as the format, then OK.

You can save the new image right over the old one, since all you did was add default metadata. When you re-open the image, the text tool should work normally again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

This was so helpful!  Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2018 Mar 08, 2018

Copy link to clipboard

Copied

Thank you so much! this was very helpful!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Thank you!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2018 Apr 19, 2018

Copy link to clipboard

Copied

I've read through all of these tips and tried them. I'm having the same issue where my text is not appearing. Any other advice?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2018 Jun 12, 2018

Copy link to clipboard

Copied

I found a different solution for a similar problem:

Faux Bold was turned ON in the Characters panel and some fonts refuse to render at all with that option. They just disappear.

Turn that off and voilà! I hope I just saved a few hairs of others in similar misery.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2018 Nov 12, 2018

Copy link to clipboard

Copied

This was my problem. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2020 Apr 05, 2020

Copy link to clipboard

Copied

Thanks. That worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2018 Nov 13, 2018

Copy link to clipboard

Copied

Had the same problem. Worked for me aswell. Was really frustrating to sort it out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2020 Jul 05, 2020

Copy link to clipboard

Copied

Try lowering or increasing the resolution.

 

I had this problem and the reason was I put the max resolution, and got this "scratch disk" error. Then the lowest resolution did not let me see the letters.

 

So I just left the default since I was just trying out different settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

LATEST

I just found your thread and I had the same problem. I fixed my issue via ideas in this thread. In my photoshop I was adjusting a invoice. I had to change a title on the top line of the page and the text dissappeared as soon as I tried to change it. Size was the same. Color was the same. it was there a second ago... I tried every font. all just a blank highlighted area where my text should have been.I turned off every other layer. nothing. I tried resizing it. nope. I changed the color and like magic I had red text instead of transperent. Change back to black- problem solved.  IDK why it did that but maybe this can help someone else too...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines