Vert/horiz rulers, usually on left/top edges of window, appearing in middle of screen

Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Please see the attached screen grab. I don't know what happened to cause this. The rulers are crossed in the window. The usual rulers are still on the left and top of the window. Do I just restart my machine? Or is this some kind of feature I've never seen before and can reset?

 

Screen Shot 2022-01-21 at 4.34.05 PM.png

TOPICS
macOS

Views

112

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jan 23, 2022 Jan 23, 2022
Before getting this reply, I tried in order: restarting Photoshop (twice), restarting the machine (once), and finally, uninstalling Photoshop and re-installing. For all my complaints about CC moving to a subscription model, it has made the last option much less involved, if rather drastic . . . but that seems to have fixed it. I've turned off "Enable Native Canvas Rulers."My case may be related to connecting to and disconnecting my MacBook from an auxiliary display, which moves windows around in...

Likes

Translate

Translate
Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Problem solved. Not so much solved as disappeared. So apparently something just glitched out. I restarted Photoshop and it was still there, which was when I posted. Restarted a second time and it was taken care of. Sorry for wasting people's time.

 

Rob

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Apparently I'm not done wasting people's time. Because the problem is back. I've restarted my machine. What do I do next? Restart Creative Cloud? Find some plist to delete? This has just ended my progress on work that was due weeks ago that was just about to get done.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

@Rob the Slob 

 

Others are also reporting this issue of "ghost rulers" and the engineers are aware of it. See this thread and upvote it in the upper right.

https://community.adobe.com/t5/photoshop-ecosystem-bugs/p-ghost-rulers-appear-in-middle-of-image/idi...

 

One solution there is to go to Preferences > Technology Previews > uncheck the “Enable Native Canvas Rulers” >  restart Photoshop. Tell us if that works.

 

Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

Before getting this reply, I tried in order: restarting Photoshop (twice), restarting the machine (once), and finally, uninstalling Photoshop and re-installing. For all my complaints about CC moving to a subscription model, it has made the last option much less involved, if rather drastic . . . but that seems to have fixed it. I've turned off "Enable Native Canvas Rulers."

My case may be related to connecting to and disconnecting my MacBook from an auxiliary display, which moves windows around in all apps. I don't know, just the wildest guess. Praying very hard this doesn't come back, because I really don't have the time right now for tech glitches.

Thanks very much, jane-e and gener-7, for the replies.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

You're welcome, @Rob the Slob .

 

Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2022 Mar 30, 2022

Copy link to clipboard

Copied

where do you find 'enable native canvas rulers'

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

LATEST

@defaultcywucj5zceim wrote:

where do you find 'enable native canvas rulers'


 

Preferences > Technology Previews

 

Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

That's not normal. I've never seen that in all the years I have had Photoshop.

 

Here's  a few things to try:

Use a different Workspace. Try "Essentials".  Window > Workspace > Essentials  If it is already chosen, then select "Reset Essentials." If you are using your own custom workspace, try resetting that as well.

 

Under Edit > Preferences > Technology Previews, checkmark "Deactivate Native Canvas." Restart Photoshop.

 

And finally, it may be due to a corrupt settings file. You would need to Reset Preferences:

reset prefs 2020.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines