White outline around my masked layers

New Here ,
Sep 07, 2017 Sep 07, 2017

Copy link to clipboard

Copied

I'm getting a fine white line around my masked layers when place against a background in a multi-layered file.  I'm using the quick selection tool then checking the Select and Mask box...doing some edge refinement and Outputting as New Layer with Layer Mask.  I'm then dragging this layer into my background.  That's when I see the fine white lines around the whole unselected image (top green figure is the image I started with- the masked portion is on the below black background photo with the fine white lines around the original border).

I don't believe this is actually part of the image...I only say this because I exported the layered image with the fine white lines to a high res JPEG file and opened it- no white lines appear.

They are more annoying than anything else.  If my technique is the issue any recommendations would be appreciated.  if there is a way to remove them- even better.

Thanks for all comments...

Views

16.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Engaged , Sep 07, 2017 Sep 07, 2017

As Chuck said, viewing at 100% can determine if lines are really there. What might be happening is that those white lines are really there--but when you export a hires JPEG--however you are viewing it--it might not be showing you a super detailed representation of what is actually there (this can also be how your monitor is configured versus how Photoshop is configured. In addition to this, I also know that Select and Mask can fail at times to really clear up some detail depending on the type of

...

Likes

Translate

Translate
Adobe Community Professional ,
Sep 07, 2017 Sep 07, 2017

Copy link to clipboard

Copied

Do you see this at 100%. You will often see artifacts if your image isn't at 100%.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

Chuck- yes...I do see the lines at 100% as well as other magnifications- both zoomed in or out...so I guess the lines are there

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 07, 2017 Sep 07, 2017

Copy link to clipboard

Copied

As Chuck said, viewing at 100% can determine if lines are really there. What might be happening is that those white lines are really there--but when you export a hires JPEG--however you are viewing it--it might not be showing you a super detailed representation of what is actually there (this can also be how your monitor is configured versus how Photoshop is configured. In addition to this, I also know that Select and Mask can fail at times to really clear up some detail depending on the type of selection you are performing. Its a wonderful way of selecting--but not always the cleanest.  To clean up your lines--just Select Your Layer Mask that was created and try to use black (RGB,0,0,0) brush to brush out the white lines. If this works--you'll have your answer--the lines were a product of a bad selection. Please report back and tell us if any of this worked! Happy to help you out further!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

Kristian- thanks...this was helpful and confirmed what I stumbled across on my own...The lines were "real".  I used the brush tool to get rid of them and everything looks great.

Thank you and Chuck for responding...I've been using Lightroom for years and over that past year just diving into Photoshop.  I love it but it can be overwhelming- especially when you think you are doing something correctly but things aren't happening the way you thought they should!

This was my first time asking a question in this forum and it was very successful.  Thanks again.

Jim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2020 Oct 04, 2020

Copy link to clipboard

Copied

Hi Kristian, I know this thread is old, but I actually just wanted to pick it back up as I'm experiencing the same issue. Brushing away the white exterior outline of the mask (which shows up in exported tiffs/jpgs etc) isn't really a good enough work around for me, so I just need to solve the problem at the source. What causes this white outline? Is it a bug or a setting that I can change in order to solve it? Even something as basic as getting the mask to expand on the outward sides by 1px automatically would do it. Just the "paint it away" solution is a frustrating waste of time for something that shouldn't be there in the first place. Thanks a lot, Josh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi Joshs,  did you figured out how to fix the white line? I have the same issue and it is so annoying.

could you tell me, if you know it please?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Unfortunately no fix and no response from Adobe... just keep having to paint out the edge of the mask.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

@joshs90456837 how are you getting the same issue? via select and mask? 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

LATEST

Yes, it is via select and mask.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines