3d photoshop camera being too small, or background colour change.

New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

When I was using the 3d photoshop, the field which is usually white, turned black, and when I try to rotate my object wherever it originally was would remain a white transparent background.

Talos5CD9_0-1624393345146.png

 

Here you can see a white square where the object was originally positioned but when I rotate it it does not change.

TOPICS
Problem or error

Views

311

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry that Photoshop 3D camera is not working as expected.

 

Would you mind checking the steps mentioned below as known issues in Photoshop and let us know if that helps?

 

Issue

Workaround

Photoshop may crash after closing a 3D document without saving.

Restore Photoshop's preferences to default and try again.

In Photoshop 22.4 (May 2021), use of 3D features (Text extrusion, Lighting Effects, Normal Map and Bump Map filters) may not update the screen properly or render the correct results.  

We recommend using the Tech Preview option for overriding Photoshop’s native canvas mode to continue to use the 3D features.

Go to Preferences > Technology Previews, and check the item Deactivate Native Canvas, then restart Photoshop. 

In Photoshop 22.4 (May 2021), you may notice irregular color artifacts in your 3D document.

This could happen if you create or edit a document while using the Deactivate Native Canvas override, then switch back to normal mode to view the file. The color artifact is not saved to the file and is only a display aberration. 

Turn off/on visibility of that layer to reset it.

In Photoshop 21.1, 3D shadows are only partly rendered.

 

  1. Select the mesh group. 
  2. In the Properties panel, click Reset All. 
  3. Select a 3D Camera tool and move the camera.
  4. Render the 3D model again.  

 

In Photoshop 20.x and higher:

  • OpenGL on canvas  > Model may look different.
  • Material model > Model may render different.

The 3D Material model in Photoshop has changed and it is transitioning to the 3D material model used by Substance and Dimension

  • OpenGL on canvas  > Model may look different.
  • Material model > Model may render different.

The Ray Tracer has not changed, however, the material model has changed and Photoshop tries to match previous versions as close as possible. However, there will be files that will no longer look the same because how Photoshop handles certain materials differently.

For example > Photoshop went from Specular-Glossiness to Metal -Roughness

Photoshop is moving to Physically Based Rendering (PBR) > this is a method of shading and rendering that provides a more accurate representation of how light interacts with surfaces.

To make a Reflection in previous versions you just had to move the Reflection slider to 100%.

For current Photoshop in 2019 and above you need to move the Metallic slider to 100% and move the Roughness slider to 0% for full 100% Reflectivity.

Illumination is gone but Glow is now included. 

These visual changes are expected with the changes to the Material Model.

3D volume feature producing incorrect results for text layers.

The issue is intermittent and related to GPU resources. Try restarting your computer.

 
 
Thanks,
Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

LATEST

I belive any of these solutions worked for me. First I tried to restore the default preferences in photoshop, which failed, as well as restarting my computer. I have not tried to do it manually but I not have high hopes for it to work that way. I've also tried to turn of my visibility layers for the meshes, but that did not work either. I have not tried to property panel, as I can not find it, and do not know if it is available in the version I own. The same is for the opengl on canvas. Heres better illustrating my problem:https://www.youtube.com/watch?v=c3A74TBDgcY

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines