Adobe Photoshop 2020 Not showing images.

New Here ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

Hello. I just updated Photoshop 2020 and every time I open a file is all white. I can see my layers on the layers tab but can't display my layers on the workspace.

Has anyone encountered this problem?

TOPICS
Performance, Problem or error, Windows

Views

26.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , Jan 07, 2020 Jan 07, 2020
Go to Photoshop--> preferences--> performance-->check the legacy compositing then exit photoshop and then relaunch photoshop.That's what the help chat told me to do and it worked.

Likes

Translate

Translate
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

I'm having the same issue. Fingers crossed this can be fixed asap.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

Yes - I'm having the same problem NOW only my images all show up BLACK. I'm a professional photographer and I'm dead in the water now. I can't believe this. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 04, 2020 Jan 04, 2020

Copy link to clipboard

Copied

I have the same issue with you. Have you resolved it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

I do not expereince it at all. 

Please contact Customer Care: http://helpx.adobe.com/contact.html They can login to your system.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

Go to Photoshop--> preferences--> performance-->check the legacy compositing then exit photoshop and then relaunch photoshop.

That's what the help chat told me to do and it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2020 Jan 12, 2020

Copy link to clipboard

Copied

It's work. Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2020 Jan 22, 2020

Copy link to clipboard

Copied

Life saver! Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 10, 2020 Feb 10, 2020

Copy link to clipboard

Copied

I had the same issue just now -- all black... so crazy!! THANK YOU!!  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2020 Feb 11, 2020

Copy link to clipboard

Copied

Thank you, I had a black screen and this did the trick. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

Thank you! Thought I was going mad! 😁

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

This worked for me! Thank you for saving the work day!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2020 Mar 06, 2020

Copy link to clipboard

Copied

Thank you!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

I don't see legacy compositing in performance under preferences, any ideas? I just updated to 2020 and images are white. 😕

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

I fixed mine through another solution. Try going Photoshop>Preferences>Performance>Graphics Processor Settings> Uncheck Use Graphics Processor. Click OK and close the window, if this doesn't immediately work try and restart Photoshop too. I went straight back in and re-checked Use Graphics Processor and it worked fine (Photoshop uses GPU for RAW, perspective warp, 3D and blur effects amongst other things, so you generally want it in use). It must just be a glitch in the update that temporarily incapacitates it. Hope this helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Thank you! I had to try this a couple times, but it worked the second time. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

It worked! Thank you so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

Thank you Lexidesigns! That worked for me!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Thanks

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2021 May 02, 2021

Copy link to clipboard

Copied

Thank You so Much. This saved me a lot of time

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2021 May 02, 2021

Copy link to clipboard

Copied

Thanks for sharing - this fixed my problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

This did it for me! Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Thank you - this works.

 

NB for those having no success with Legacy compositing route, on my PS it says they no longer use it.

This solution worked for me thanks to Lexidesigns

Photoshop>Preferences>Performance>Graphics Processor Settings> Uncheck Use Graphics Processor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Thank you SianRich.. the Legacy Composting has beeen removed on my version, but your work-around worked perfectly. Thanks!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Hi!

In my current version (Photoshop 22) the "Legacy compositing" checkbox has been removed, but your suggestion worked as a charm. No restart required.

 

Adobe notification about "Legacy compositing":

https://helpx.adobe.com/photoshop/kb/legacy-compositing.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines