Black & White adjustment problem with its color picker and smart objects

Explorer ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

I've tried to use the Black & White adjustment on a smart object layer I had just converted and the color picker function, where you can click on a spot and slide the mouse left and right, so it would only move the corresponding colors in the B&W adjustment box, did not work.

 

It behaves as if I had another Smart filter on the layer, but with the visibility turned off: the color picker pointer doesn't change to that hand with arrows to both sides and nothing changes.

 

I've tried doing the exact same thing with just a copy of that layer, bevore converting it to a smart object, and it worked just fine.

 

I know I have done this before on a smart object layer. Is that a bug or am I missing something?

thanks in advance and sorry if my questioning and describing was confunsing

TOPICS
Bug, Problem or error

Views

842

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Seems like I can't edit my first post, but by color picker I meant eyedropper

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Best to send us a screenshot and show us excactly what you are doing so we can check it out. 

 

Always good to inlcuse OS and platform...

Chana

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

1.png

So this is the original image, which I've made a copy of the background layer to appy the adjustment.

 

 

 

2.jpgOn the Black & White adjustment dialog box, if I hover my mouse over the image and outside that box, an eyedropper takes place as the cursor. If I click and drag my mouse on any point, the eyedropper will change the respective color slider to that point. In this case, I've chosen the yellow from the police line. Everything works fine.

 

 

 

3.jpg

In this case, I copied the BP layer and converted it into a smart object, so I could apply those adjustments non-destructively. However, when I click on the image to select a color and use that drag function, the cursor remais as an eyedropper and nothing happens. See how in this image, the slider doesn't become highlighted, as the previous one did. 

I can manually move the slider and the adjustment will work, but I was wondering why this "click and drag" function is not working properly. 

My PS version is the latest, 22.4.2

I'm running it on a PC, with Windows 10 Pro v. 10.0.19041 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 16, 2021 Jun 16, 2021

Copy link to clipboard

Copied

Hello, Chana

Did you have a chance to check it out?

Thanks,

Pedro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

Hi, you can apply the Adjustments layer instead to convert an smart object

EugenioNYC_0-1624115966290.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Hi, Eugenio

English is not my first language, so I'm sorry if I come out as rude, but I am aware of other ways to apply that adjustment!
I was trying to understand if something I was doing was wrong, or if it was a bug - and if so, where should I report it.

 

Thanks for your reply!
- Pedro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Hi Pedro, No worries and what other languages do you speak?

 

About the issue you have

I don't have a solution but try a few things

1- Check your permissions settings, (screen recording permission) so that the Eye Dropper can pick any color

2- Try to reset the preferences will work, here the instructions:

https://helpx.adobe.com/photoshop/using/preferences.html

3 Another option: install a previous version of Photoshop

Go to the creative cloud app and click on the 3 dots next to Photoshop app to see more options and select other versions

you can install a previous version of Photoshop and maybe that will work, sometimes there are bugs and you have to update the system

Let me know if that works

 

There are a few issues with Photoshop that you can check here

https://helpx.adobe.com/photoshop/kb/known-issues.html

 

Regards

Eugenio

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Eugenio, good evening

I speak portuguese.

 

I don't have that kind of setting on Windows (Mac has that screen recording permission) and I've ran Photoshop as administrator to see if anything changed, but all kept the same.
Resetting my preferences also didn't do anything.

 

However, when I was trying that eyedropper feature again, I changed the Sample Size from "Point Sample" to "3 by 3 Average" - and all the other "x by x Average" and it worked.

I guess something is indeed wrong with that feature, but only with the Point Sample option.

I guess I'll just keep using this version and see if it changes on a next one and just work around this - which actually isn't a big thing.

 

Thank you very much for your time and patience!
- Pedro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

LATEST

I am so happy you figure it put (Muito feliz :), eu falo espanhol (Chile) I can read portuguese and I understand 50% but I speak just a few words 🙂

 

Take care

E

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines