Dynamic object

Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Hi,

 

I make a Smart Object in my PSD as I open my Smart Object the layers appear in the Layer menu, but they are not visible on the artboard.
this is the first time that it happens to me. I've been trying to understand for two days

TOPICS
Problem or error

Views

807

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jun 01, 2021 Jun 01, 2021
I suspect the psb may be »badly formed« in some way that does not seem to make sense.  Does it happen everytime you convert a stack of Layers to a Smart Object?  If so Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point to trouble-shoot: https://helpx.adobe.com/photoshop/using/preferences.html https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

Likes

Translate

Translate
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Could you please post screenshots with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Yes, of course

 

PSD PROJECT.PNGSmart Object.PNG

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Are there any Layer Comps? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

I'm not sure I understand your question, on the pictures you can see everything,

the first image is the psd and the second is the dynamic layer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Is there anything listed when you show 

Window > Layer Comps

 

Can you provide the file? 

If you make any changes in the Smart Object (add a Solid Color Layer for example) and save it is the change manifested in the containing document? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

I send you the PSD.

 

when I create a Solid Color Layer in the dynamic object, it works

 

https://we.tl/t-9lLESJU04B

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Interesting, the Layers in the SO do not seem to »have« a Blend Mode, Opacity, Fill … 

Screenshot 2021-06-01 at 14.56.34.png

 

By using Layer Via Copy (cmd-J) on the Layers individually I can generate Layers that behave as expected, but aside from that cumbersome work-around I have not been able to rectify the situation so far. 

Screenshot 2021-06-01 at 15.02.59.png

 

Maybe post a Report (with the file) over on 

Photoshop Family

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

i understand what the problem is, it's really weird, b

ut i will do your technique as a solution (cmd-J).

 

Thank you a lot

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

I suspect the psb may be »badly formed« in some way that does not seem to make sense. 

 

Does it happen everytime you convert a stack of Layers to a Smart Object? 

If so Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point to trouble-shoot:

https://helpx.adobe.com/photoshop/using/preferences.html

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

LATEST

Does it happen everytime you convert a stack of Layers to a Smart Object?No, this is the first time this has happened,

i will do what you say

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines