How do I turn off this box in text box?

New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

I recently had to reset my preferences and I've been manually configuring settings back to how I had them.  I have no idea what the box indicated in my screenshot is, though, and I'd like to remove it.  I've already turned off the Glyphs popup, but this box is still showing.  I'd appreciate any help to get rid of it.  Thanks!

TOPICS
Problem or error, Windows

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

 

Prefs > Type > Uncheck Enable Type layer glyph alternates.

janee_0-1624402178511.png

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Hi, Jane, thanks for your post. I had already unchecked that box. That's what I meant when I said "I've already turned off the Glyphs popup". Any other ideas?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Hi @nrz0 ,

 

No, I have no other ideas, sorry! Can you check the setting in Preferences one more time (to humor me) and confirm the setting is unchecked?

 

What happens when you select the "t" in your sample? Do the alternate glyphs appear?

 

 

Here's what Help says:

"On-canvas glyph alternatives

"When you're working in a Type layer, you can select a glyph to quickly view alternatives to it right on the canvas. Clicking the  janee_3-1624404025664.png icon in the alternatives grid takes you to the Glyphs panel.

 

janee_2-1624404008258.png
"On-canvas glyph alternatives

 

"If necessary, you can turn off this behavior. To do so, deselect Preferences > Type > Enable Type Layer Glyph Alternates."

 

 

~ Jane

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Here are screenshots from today showing my Type settings in Preferences and what I'm seeing when highlighting text in a text box.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

GPU driver go a little kablooey, maybe? Have you tried turning off GPU acceleration via Preferences > Performance > Graphics Processor Settings to see if that makes any difference?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Also, highlight only the letter with the box under it to see if the glyph alternatives appear.

 

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Nope, that didn't make a difference.  I did note that when I unticked "Use Graphics Processor" and restarted the program, another problem returned where my text has a black background (the reason I reset my settings in the first place).  Checking it back and restarting Photoshop resolved the black box issue this time, though.  But in either case, the Glyphs box remained.  For the record, my onboard Intel graphics are disabled in the BIOS and I'm using an AMD FirePro WX 5100.

This isn't a huge deal... just an annoying visual blip in a very visually-oriented program.  I was hoping it'd be a quick Preferences fix, but it sounds like that's not the case.  I'm going to let this one go, unless someone knows exactly what it is and how to to turn it off.

Thanks everyone for your responses.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

That card's no slouch and you did the right thing in disabling your Intel GPU. Did you try an updated driver? AMD's website last updated them in March. Similarly, this might be something the FirePro's drivers are exploiting in Photoshop. It might be a good idea to contact AMD to let them know of the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

I don't want to mess with different drivers at this time.  Photoshop is a secondary program I use; most of my time is spent in AutoCAD, which is super finicky with drivers.  The current drivers I have are currently working with AutoCAD, so I don't want to mess that up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

You have a light interface theme. Is it the same with a dark theme?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

See if going to Photoshop>Preferences>Type and unchecking Fill new type layers with placeholder text solves the issue.

 

 

pl.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

I have figured out that the box is font-specific.  It doesn't appear for most fonts, but it does for some.  I'm not sure why it doesn't go away when the glyph alternates are turned off, but it will be a non-issue for me most of the time.

For the record, changing to dark mode and unchecking autofill didn't have any affect on it.

Thanks everyone for your suggestions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Hi @nrz0 

 

Some typefaces do not have glyph alternates at all. Others have alternates that vary with the specific typeface, depending on what the type designer decided to design. Here's the same word with different glyph alternates.

 

I didn't think dark mode or autofill would have any effect.

 

If you are curious, try this:

  • find a typeface where the gray box does not appear
  • enable the checkbox to show the glyph alternates and look again
  • do any glyph alternates show for that typeface?

I'm going to guess "no", but I could be wrong. I think the typefaces where you don't see the gray box don't actually have alternates built into them (at least not with the letters you have typed.)

 

~ Jane

 

 

janee_0-1624552335237.png

 

janee_3-1624552441797.png

 

 

 

janee_1-1624552374736.png

 

janee_4-1624552484095.png

 

 

janee_2-1624552407135.png

 

janee_5-1624552566007.png

 

janee_6-1624552709834.png

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Yes, that was my conclusion as well.  I didn't test every font, but that seems to be the case.  In any case, there doesn't seem to be any user control over whether the glyph box appears or not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

You could report it as a bug to the product developers for Photoshop here:

Adobe Photoshop Family

 

 

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

That's alright.  It's probably a feature for other people, as it lets you know there are glyphs there so you can rigiht-click it and select alternate glyphs if you've disabled the automatic pop-up feature.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

LATEST

I see the same here and it appears when alternative glyphs are available in the font for the type highlighted. If alternative glyphs are enabled in preferences then hovering on a letter shows those individual alternatives. The grey box though appears whether the preference is enabled or not.

 

Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines