Lighting Effects not working

New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I use Windows 10.

Ever since I updated to 22.4.1, my Render > Lighting Effects isn't working. There's no guide to move the light and I keep getting two baffling errors.

 

The first error insists that "Use Graphics Processor" should be checked... It is checked. I've even unchecked and rechecked it.

FG74udT.png

The second error insists I don't have enough RAM... I have 32 gigs of RAM.

bbo9b9s.png

 

When those two errors pop up it outright refuses to open the Lighting Effects workspace altogether but sometimes it WILL open it... only I won't be able to make any changes on the image. It'll show that there's some kind of spotlight out but there's no way to move it and the sliders do nothing to change it.

 

GWDFMRZ.png

 

Repair attempts I've made:

 

1 - I've made sure that my video card driver is up to date. It is.

2 - I've selected View > Show > All to see if the UI was hidden. The controls still refuse to show up and the sliders still don't work. They move, but the light doesn't actually change.

3 - I've uninstalled and reinstalled Photoshop altogether. Still getting the errors and inability to manipulate the spotlight in any way.

 

I am a graphic designer that uses photoshop practically daily. I took a couple days for myself and when I came back it updated to 22.4.1 and now this is happening. Please help, I need to be able to use lighting effects for my job!

TOPICS
Bug, Performance, Problem or error, Windows

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 21, 2021 May 21, 2021
Hi Try enabling this option in preferences and restarting Photoshop to see if it helps

Likes

Translate

Translate
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Hi

Try enabling this option in preferences and restarting Photoshop to see if it helps

2021-05-20 09_59_13-Window.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Thank you, that seems to have done it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

You're welcome 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

So happy I found this! Was having the same problem and couldn't get it fixed. Finally!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Thank you also.  I was having the same problem for a long time and this fixed it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

All this has done is grey out lighting effects. Any other suggestions would be welcome. I am using Mac with Big Sur 11.3.1 with an intel chip Macbook Pro 16" 6 core with 32gb Ram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

This did the same for me--greyed out Lighting Effects!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Me too. Sigh.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

I've given up testing to see if anything works!!  Should be Adobe's job before they release a new version.

Summary: Reinstalled 3 times, checked that Deactivate Native Canvas flag - the filter works once then go back to re-edit same image or a new image, and the effect doesn't function properly. Tried resetting Preferences, still no luck. Enough is enough!! Previous version I guess 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

This solution fixed my problems... Thanks so much... Lighting Effects are one of my favorite in Photoshop CC...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Was your fix done on a Mac or Windows? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Mine was on Windows 10 if that helps?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

LATEST

Windows 10

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

That's It!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Worked like a charm, Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines