Phosohop 22.3 1 crashes constantly and is virtually unusable on Windows 10

Explorer ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Using Photoshop 22.3.1 on a Dell XPS17 9700 with Core I7 10th gen, 64GB ram, Nvidia GeForce RTX 2060, Windows 10.0.1.19041, I get a crash after a few simple edits to a PSD file (e.g.create an adjustment layer, curves adjustment, duplicate layer) and generally find Autosave has not saved anything.  Updated to ver. 22.4, with same result.  Found that Photoshop was unable to identify video card.  Chatted with Adobe, renamed preferences file and restarted.  Photoshop then did identify the video card and worked for a while.  Then started crashing again.  Removed GeForce Experience app - crash. Reinstalled latest video driver – crash.  Photoshop still identifies video card, which is not using OpenCL.  Returned to ver. 22.3.1 – crash.

 

 

{Thread title edited by moderator}

TOPICS
Crash or freeze, Problem or error, Windows

Views

264

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 20, 2021 May 20, 2021

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Photoshop. Please update Photoshop to version 22.4.1 & let us know if the issue persists. Also, please ensure you have all available Windows updates installed on the computer.

 

If the issue persists with Photoshop 22.4.1, you can try disabling the option to Use Graphics Processor from Photoshop by going to Preferences, then Performance. Once done, quit & relaunch Photoshop to check if that helps.

 

If it does, you can check out: https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

 

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 20, 2021 May 20, 2021

Copy link to clipboard

Copied

LATEST

Besides having the program ignore the video card, I suggest using the Reset Preferences on Quit option located in uner the Preferences.

Preferences > General

warmly/j

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines