PhotoShop v22.4.2 error loading index color images

New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Hi, We have a problem that 8-bit index color images that used to load fine no longer load in PhotoShop v22.4.2, it used to work in versions v20 and earlier and at least up to  v21.2.9.

 

Could it be that the new version checks for TIFF tags (e.g. SubFileTye) which were not checked before?

 

BTW, SubFileType seems to have been depricated in favour of NewSubFileType in the TIFF standard but not in EXIF? But PhotoShop seems to use SubFileType? This may be correct behaviour and not the current problem. Just a thought.

 

Any ideas? Why our Index Color image reading may have changed in V22.4.2?

 

Moderately urgent to fix this problem.

 

Thanks, Danny

TOPICS
Bug, Import and export, Problem or error

Views

373

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Could you do some more testing?  I just opened a RAW Image in CS6 via ACR 9.1.1.  16bit ProPhotoRGB converted to sRGB the mode 8 then mode index color and saved an Index color Tif.  I have no problem opening that Tif in 22.4.2 on Windows 10.

 

image.png

 

 

 

 

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Hi JJMack, many thanks for taking a look at this.

The output we have that used to load into PS v21.2.9 (but won't now load in v22.4.2) is generated from non-Adobe code.

We can read the file into PS as 8-bit contone and then save it out from V22.4.2 which then loads fine in both PS versions.

The PS->FileInfo>RawData for the two version of the file is here:

 

This versiom of the file only opens in Phosotshop V20.0.2 but not in V22.4.2 (File info from PS 20.0.2):
______________________________________________________________________________


<x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="Adobe XMP Core 5.6-c145 79.163499, 2018/08/13-16:40:22 ">
<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
<rdf:Description rdf:about=""
xmlns:xmp="http://ns.adobe.com/xap/1.0/"
xmlns:tiff="http://ns.adobe.com/tiff/1.0/"
xmlns:dc="http://purl.org/dc/elements/1.1/"
xmlns:photoshop="http://ns.adobe.com/photoshop/1.0/">
<xmp:CreatorTool>ScreenPro (ACv3_1drop), using 1 droplet sizes.</xmp:CreatorTool>
<xmp:CreateDate>2021-06-14T15:05:08+01:00</xmp:CreateDate>
<xmp:ModifyDate>2021-06-14T15:04:08+01:00</xmp:ModifyDate>
<xmp:MetadataDate>2021-06-14T15:04:08+01:00</xmp:MetadataDate>
<tiff:ImageWidth>5904</tiff:ImageWidth>
<tiff:ImageLength>1280</tiff:ImageLength>
<tiff:BitsPerSample>
<rdf:Seq>
<rdf:li>8</rdf:li>
</rdf:Seq>
</tiff:BitsPerSample>
<tiff:Compression>5</tiff:Compression>
<tiff:PhotometricInterpretation>3</tiff:PhotometricInterpretation>
<tiff:Orientation>1</tiff:Orientation>
<tiff:SamplesPerPixel>1</tiff:SamplesPerPixel>
<tiff:PlanarConfiguration>1</tiff:PlanarConfiguration>
<tiff:XResolution>600/1</tiff:XResolution>
<tiff:YResolution>600/1</tiff:YResolution>
<tiff:ResolutionUnit>2</tiff:ResolutionUnit>
<dc:format>image/tiff</dc:format>
<photoshop:ColorMode>2</photoshop:ColorMode>
</rdf:Description>
</rdf:RDF>
</x:xmpmeta>
______________________________________________________________________________


This file opens in both V20.0.2 and V22.4.2 :
_______________________________________________

<x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="Adobe XMP Core 5.6-c145 79.163499, 2018/08/13-16:40:22 ">
<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
<rdf:Description rdf:about=""
xmlns:xmp="http://ns.adobe.com/xap/1.0/"
xmlns:dc="http://purl.org/dc/elements/1.1/"
xmlns:photoshop="http://ns.adobe.com/photoshop/1.0/"
xmlns:xmpMM="http://ns.adobe.com/xap/1.0/mm/"
xmlns:stEvt="http://ns.adobe.com/xap/1.0/sType/ResourceEvent#"
xmlns:tiff="http://ns.adobe.com/tiff/1.0/"
xmlns:exif="http://ns.adobe.com/exif/1.0/">
<xmp:CreatorTool>Adobe Photoshop 21.2 (Windows)</xmp:CreatorTool>
<xmp:CreateDate>2021-06-09T16:40:02+01:00</xmp:CreateDate>
<xmp:ModifyDate>2021-06-14T14:24:33+01:00</xmp:ModifyDate>
<xmp:MetadataDate>2021-06-14T14:24:33+01:00</xmp:MetadataDate>
<dc:format>image/tiff</dc:format>
<photoshop:ColorMode>2</photoshop:ColorMode>
<xmpMM:InstanceID>xmp.iid:62e5def5-945b-0145-8835-db5c48656c39</xmpMM:InstanceID>
<xmpMM:DocumentID>adobe:docid:photoshop:ac93cfc3-35fa-0349-b3ef-9fb3bd1b1f29</xmpMM:DocumentID>
<xmpMM:OriginalDocumentID>xmp.did:ce582817-d1b3-4d47-9d38-fd2548e5b440</xmpMM:OriginalDocumentID>
<xmpMM:History>
<rdf:Seq>
<rdf:li rdf:parseType="Resource">
<stEvt:action>created</stEvt:action>
<stEvt:instanceID>xmp.iid:ce582817-d1b3-4d47-9d38-fd2548e5b440</stEvt:instanceID>
<stEvt:when>2021-06-09T16:40:02+01:00</stEvt:when>
<stEvt:softwareAgent>Adobe Photoshop 21.2 (Windows)</stEvt:softwareAgent>
</rdf:li>
<rdf:li rdf:parseType="Resource">
<stEvt:action>saved</stEvt:action>
<stEvt:instanceID>xmp.iid:62e5def5-945b-0145-8835-db5c48656c39</stEvt:instanceID>
<stEvt:when>2021-06-14T14:24:33+01:00</stEvt:when>
<stEvt:softwareAgent>Adobe Photoshop 21.2 (Windows)</stEvt:softwareAgent>
<stEvt:changed>/</stEvt:changed>
</rdf:li>
</rdf:Seq>
</xmpMM:History>
<tiff:ImageWidth>5904</tiff:ImageWidth>
<tiff:ImageLength>1280</tiff:ImageLength>
<tiff:BitsPerSample>
<rdf:Seq>
<rdf:li>8</rdf:li>
</rdf:Seq>
</tiff:BitsPerSample>
<tiff:Compression>5</tiff:Compression>
<tiff:PhotometricInterpretation>3</tiff:PhotometricInterpretation>
<tiff:Orientation>1</tiff:Orientation>
<tiff:SamplesPerPixel>1</tiff:SamplesPerPixel>
<tiff:XResolution>6000000/10000</tiff:XResolution>
<tiff:YResolution>6000000/10000</tiff:YResolution>
<tiff:ResolutionUnit>2</tiff:ResolutionUnit>
<exif:ColorSpace>65535</exif:ColorSpace>
<exif:PixelXDimension>5904</exif:PixelXDimension>
<exif:PixelYDimension>1280</exif:PixelYDimension>
</rdf:Description>
</rdf:RDF>
</x:xmpmeta>
______________________________________________________________________________

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

There are many issues in Photoshop 2021.   Adobe has published  20+ issues.  Adove is still updating features in Photoshop 2021,  Photoshop 2021 is still being developed. Photoshop is not ready for general use. https://helpx.adobe.com/photoshop/kb/known-issues.html 

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

LATEST

Thanks JJMack. I looked through that list but can't see this specific issue on there. What's the best way to get this issue reported and added to that list?

 

FYI the latest version of PS that will still open the images is 22.3.1 (April release), with the 22.4.0 (May release) and later not opening them (also tested with 22.4.1 and 22.4.2 all refusing to open the files).

 

So the specific change in behaviour seems to have happend between the 22.3.1 and 22.4.0 releases.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines