Png becomes green

Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

Hello !
Sorry to ask, but I don't find any answer for my problem... So I Hope someone could have an idea of what happen to me.
I'm on Adobe Photoshop and since the last Windows update all PNG I save become "green"
(You can see under this message the "good version" on left and the "png saved" version on right)
This is not the first time it happens. One year ago I had the same problem and it finaly disappear 2 monthes later. So I don't want to unistall the windows update because it will certainly arrive again in the futur. I need a real solution please....
Where in photoshop preference or other is the real problem ?

Thank you for helping.

Have a nice day !

TOPICS
Windows

Views

131

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

Please set the Status Bar to »Document Profile« and post more meaningful screenshots taken at View > 100% with the pertinent Panels (Toolbar, Layers, Channels, Options Bar, …) visible. 

What are Photoshop’s Edit > Color Settings? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

Sorry I'm French so I'm not sure to understand exactly what you need. So here is a screen shot of all my photoshop page :

Sanogard_0-1626007743562.png

And it's in RGB

As you can see here it's white. All is ok but when I save it in PNG (save as...)
it becomes green...


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

I did not ask about the image’s Color Mode but its Color Space – which you did not set to be displayed in the Status Bar. 

Screenshot 2021-07-11 at 15.15.03.png

You also didn’t take the screenshot at View >100%, but 50%, and there is no screenshot of the resulting png that displays greenish … 

And you did not state Photoshop’s Edit > Color Settings. 

Screenshot 2021-07-11 at 15.27.15.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

Oh !!!! Is that this ??? That's realy strange ! THIS ONE is the "green version" and in photoshop it is not green and have this realy werd "profil" (I hope this is what you meaned... Sorry if not T_T...)

Sanogard_0-1626009980885.png

And here it is when it's in any other software 😕

Sanogard_1-1626010081815.png

And is that the color profil you've talked about here ? (sorry it's in french :/)

Sanogard_2-1626010151959.png


By the way. Thank you for your help and Patience ><'.... I know it's not easy to help someone who don't understand all

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

In the Edit > Color Settings you are using the Monitor Profile as RGB Working Space. 

That makes a mockery of Color Management. 

How did you arrive at that setting? 

 

The image apparently has the Monitor Profile embedded. 

Please try converting the original image to a meaningful Color Space (sRGB for web use, AdobeRGB or ECI RGB v2 for print use for example) and make sure to embed the profile in the png you are saving off of it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

I Realy don't know 😕 I've never touch it.
And there is no all you've said and I Try all of the other profile and it does not work ;_;...
It becomes red or saturated or other when I touch it T_T not the good colors
I don't understand....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

I am not saying words are not useful but when you are talking about image editing on this Forum, please: Screenshots, screenshots, screenshots … 

 

It sounds like your monitor profile is damaged. 

When did you last calibrate it? 

Please set the monitor profile to sRGB on the OS side for testing as per @D Fosse ’s advice here 

https://community.adobe.com/t5/photoshop/color-displays-incorrectly-in-photoshop/m-p/11225610 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

Ok Sorry ><'

Mmmh... I've never made it since I Have this computer (3 or 4 years ago)
And DFosse's solution does not work...
But now I know where it comes from thanks to you !!! 😄
I Will try to find how to recalibrate or ask someone for repair my monitor's profile 🙂

Thank you for helping ! ^.^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

Yes, your color settings are completely messed up. Don't ever set policies to "off", and don't ever set your monitor profile as document RGB!

 

Reset everything to defaults, and don't touch it again. The document profile and working RGB should always be a standard color space like sRGB, Adobe RGB etc. Color management policies should always be set to "preserve embedded profiles".

 

The monitor profile is managed by the operating system, not Photoshop. Photoshop just uses the monitor profile it gets from the OS. Calibrate and profile your monitor with a Spyder, i1 Display or similar. Just run the software, don't do anything except set the white point. The profile is set up in the OS automatically.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

LATEST

Ok. thank you very much. I'll doo that 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

I just noticed that you seem to have set all the Color Management Policies to Off. 

So your Color Settings appear truly messed up – please reset them to the default state (respectively the one most meaningful for your location) and read up on Color Management. 

http://www.gballard.net/psd/cmstheory.html

https://helpx.adobe.com/photoshop/using/working-with-color-profiles.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines