Spell check language keeps changing

Explorer ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

I have to keep re-setting my Character language box to English: USA. Even in the middle of a single document it will switch itself over to French or Spanish or some other language. What do I have to do to make it ALWAYS stay on English: USA ?

It looks to me as if this question was first addressed over NINE years ago. There was no satisfactory answer then, and I can't find where it has been addressed since then.

I'm on PSCC. iMac_macOS Mojave 10.14.2  and region preference is set to United States.

Thank you,

Sharron Lamb

Views

526

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 18, 2019 Apr 18, 2019

Copy link to clipboard

Copied

Hi Sharron,

Sorry that the Spell check in Photoshop keeps reverting back to languages other than US English.

This could be something related to a bad or corrupt app preferences. Could you please restore Photoshop app preferences to default and let us know if the issue still persists?

Please refer this article for instructions on how to restore Photoshop preferences: Preferences in Photoshop

Let us know if that helps.

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2020 Oct 01, 2020

Copy link to clipboard

Copied

I have this same issue. I've tried all suggestions to change the language and it keeps going back to French. Is there a resolution yet. I can't use spell check. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

Mine kept going to Spanish. I had to select and highlight the text that I had originally typed and then change each one to English. It finally worked after that. This may be something to do whenever you type your first words in a new project so that it can continue keeping everything in English. That was my only fix. (I'm on CS5).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

Thanks for the information. I'm using Photoshop CC. But I was able to figure what happened. In my case, I placed and purchased a graphic from Adobe stock via the libraries panel. For some reason, that image had a language associated with it. When I rasterized the image (no longer a smart layer) the problem disappeared. Hope that helps someone. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

this is a lame solution man. This bug tests your patience and you want all preferences to be reset? You don't know if this works, you don't care if does. If it doesn't and all preferences are reset then what do you suggest we do?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

LATEST

The language that spell-check uses is a Character-Level attribute. It's possible and common to have more than one language being checked in a single document when the document is bi- or tri-lingual, for instance. If that is not your intent, then select all text layers with the Character pallet open. The language field will read: Multiple. Change it there to your intended language.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines