Target channel is hidden

Participant ,
Dec 15, 2013 Dec 15, 2013

Copy link to clipboard

Copied

In Photoshop CC, I am constantly getting the message "Could not ...... because the target channel is hidden" whenever I try to do anything.  Every time, I check and see that the alpha channel is selected and hidden, so I select RGB instead.  Why does it keep automatically switching back to alpha?

TOPICS
Problem or error

Views

132.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , Apr 28, 2016 Apr 28, 2016
I had the same problem and found the solution:Your top panel, go to Select then in the dropdown menu uncheck "Edit in quick mask mode". Then it switches back to automatic RGB channel selection from automatic Alpha selection.

Likes

Translate

Translate
LEGEND ,
Dec 15, 2013 Dec 15, 2013

Copy link to clipboard

Copied

Are you maybe clicking on a layer mask icon in the Layers panel?

-Noel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 15, 2013 Dec 15, 2013

Copy link to clipboard

Copied

Nope.  I did have some layer masks, but they were inside layer groups that were closed and not visible.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 15, 2013 Dec 15, 2013

Copy link to clipboard

Copied

I'm not sure what you might be doing, but I haven't heard a lot of complaints here on the forum about Photoshop selecting alternate channels on its own...  Is is possible you're fat-fingering a key on the keyboard just before this happens?

I'm scouring my memory and I can't think of a time when I've had a channel made active without being able to explain it...

I can only encourage you to watch for it to happen then very carefully review what you've just done.

Next time it happens, before changing anything consider doing a screen grab and posting it here.  Maybe there's some other clue there that one of us on the forum might be able to spot.  Maybe something will be showing in the History panel that will make it clearer...

-Noel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2014 Jan 03, 2014

Copy link to clipboard

Copied

I am getting the same exact issue.

I very carefully select my layer and go to move it using the cursor, and get this error.

I look in the channels panel and RGB is no longer selected only the Alpha channel.

I edit text, save changes, go to move the layer and get this error.

This is the first time this has happened to me as a photoshop user of 10 years. I am on Creative cloud cc and just updated photoshop a few days ago..

The only fix I know of is to select the alpha channel and delete it..

Screen Shot 2014-01-03 at 9.38.40 AM.pngScreen Shot 2014-01-03 at 9.38.50 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2017 Oct 16, 2017

Copy link to clipboard

Copied

THANKS! That was it! I was ready to push my laptop off the desk.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

3 Years later and works like a charm!! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2020 Mar 02, 2020

Copy link to clipboard

Copied

Worked for me just now too. It was because I had created a mask and although I wasn't using it, it was still a channel apparently.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2016 Apr 28, 2016

Copy link to clipboard

Copied

I had the same problem and found the solution:

Your top panel, go to Select then in the dropdown menu uncheck "Edit in quick mask mode". Then it switches back to automatic RGB channel selection from automatic Alpha selection.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Worked, thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2018 May 06, 2018

Copy link to clipboard

Copied

Thank you very much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Thank you!! This solved it for me too

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

LATEST

THANKS!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 12, 2017 Aug 12, 2017

Copy link to clipboard

Copied

In my case I found out that when I was accidentally right clicking on the curves icon, when I meant to left click on it. I have a wireless mouse and it's easy to do:( This had the effect of creating a layer mask in a curves panel, instead of just a layer with curves adjustment. Since the curves panel showed up right where I expected it, I failed to notice that I was creating a layer mask with a curves in it. Then I went to use my eraser and got the same message. It kind of messed me up for a while, but I solved it by deleting the unwanted layer, and then deleting the alpha channel which was also inadvertently created. I had a similar problem with using the option key when using the quick selection tool. I heard a click, click, click, etc. and then my keyboard was inactivated. I resolved this by hitting the option key multiple times until I heard the click, click, etc. again. There are numerous ways to get in a weird setting that is not helpful, and then it takes forever to figure out what happened and how to fix it. Especially since it's unintentional, a person has no idea what they might have done. Luckily sometimes there is a sound to indicate that something weird happened.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2017 Aug 25, 2017

Copy link to clipboard

Copied

You are in quick-mask mode

Push the letter Q and all your troubles will go away...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2018 Jan 09, 2018

Copy link to clipboard

Copied

Oh thank you so much

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2018 Feb 28, 2018

Copy link to clipboard

Copied

who wold've thought pressing Q is the only answer

Kudos!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2019 May 24, 2019

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

Hi All,  Its been so long since I've used photoshop.  I I am unable to use the type tool after creating several layers.  The pop us says "Could not use the type tool because the target channel is hidden."  I do not know what "the top panel" is where I could deselect masking.  Thanks for any help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines