• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
7

Anyone issues with Windows 10/11 very slow navigating File Explorer? (but only when PSE open!)

New Here ,
Jan 10, 2024 Jan 10, 2024

Copy link to clipboard

Copied

 

Really wierd, without PSE 21 Organizer open, no issues cutting, pasting, moving files around Files Explorer.

But once PSE open, and try to copy an image from the organizer to a Folder in file explorer, everything becomes painfully slow selecting, copying, pasting any files within the explorerer. I turned off watched folders think may be a cause, but no issues. Somehow PSE seems to be affecting the Windows File Explorer. I

Tried a few things and online hints but to no avail and looked extensively online, but can't seem to see any similar issues.

My machine is reasonablty fast i7, 10th gen, lots of RAM, so don't think issue there.

Any suggestions be great!

🙂

 

TOPICS
How to , Import and export , Organizer , Windows

Views

141

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 10, 2024 Jan 10, 2024

Copy link to clipboard

Copied

I've never experienced what you are describing, but I do have some advice for you:

 

Don't use File Explorer for any file management if you are using the Organizer.

 

The files that you have moved, deleted or renamed will become missing files in your catalog.  Instead, use the Organizer's My Folders panel on the left to make your changes by click and drag.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

LATEST

I was facing a similar issue with Photoshop Elements 2018 after the upgrade from Win 10 to Win 11.. After some investigations it turned out that somehow Avast Antivirus was causing this issue. Uninstalled Avast and installed an

other AV, now everything is fine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines