• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't reinstall old Photoshop Elements

New Here ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

I have been using Photoshop Elements 1.01 since I bought my computer in 2007.  My machine crashed last year and the hard drive was reformatted by a technician who installed current versions of the basic software.  I reloaded several of the programs which I used regularly.  However, Photoshop Elements would not install.  I get the error message that I need Internet Explorer 4.0 or greater to install it.  My Computer has IE 11.  Is there anything I can do to reinstall my PE?

Views

274

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 22, 2018 Nov 22, 2018

Copy link to clipboard

Copied

Try the steps outlined by kcmdental in post #8

Elements needs version 4 or newer of Internet Explorer to install?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2024 Feb 18, 2024

Copy link to clipboard

Copied

The link above doesn't work.  I have Photoshop Elements v 4.0 that I successfuly installed on windows 10 a few years ago.  I now have windows 11 and a message is poppimg up regarding IE 4.0 or later.  Is there a solution please?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 19, 2024 Feb 19, 2024

Copy link to clipboard

Copied

Danny3552,

 

Your sure it's photoshop elements 4 you have?

 

Can you post a screenshot of the message about IE 4.0?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2024 Feb 24, 2024

Copy link to clipboard

Copied

LATEST

Turns out it was user error.  I inserted a bundles disk by mitake and there must have been sone content on that requiring Internet Explorer.  I've installed it from the correct disk (which took a few minutes to load the installer!) and seems to be running fine now.  I got a windows compatability warning during the install but it did that with windows 10 too and worked resonably well.  I can live with the odd glitch here an there though as I only use it occasionally to tidy up images.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines