Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


elements 20 on Mac

New Here ,
May 25, 2020 May 25, 2020

Copy link to clipboard

Copied

I have a Mac Catalina Version 10.15.4.  Elements 2020 is compatible with Version 10.15 - is that the same as 10.15.4?

TOPICS
Mac

Views

417

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 25, 2020 May 25, 2020
Yes. Elements is compatible with the 10.15 operating system including minor version updates: so 10.15.1, 10.15.2, 10.15.3, 10.15.4 and so on. It's usually written in shorthand: 10.15.x which includes all minor version updates..

Likes

Translate

Translate
Adobe Community Professional ,
May 25, 2020 May 25, 2020

Copy link to clipboard

Copied

LATEST

Yes. Elements is compatible with the 10.15 operating system including minor version updates: so 10.15.1, 10.15.2, 10.15.3, 10.15.4 and so on.

 

It's usually written in shorthand: 10.15.x which includes all minor version updates..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines