Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Elements 2018 won't install

New Here ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

I bought Elements 2018 in August 2018, Adobe says it's 64-bit, but when i try to install it on a new macbook pro (64-bit) the info for the app says it's 32-bit. Surely I don't have to buy a new version?

 

TOPICS
Download and install, Mac

Views

92

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

A new Macbook needs new apps. 64-bit is just one small part of this, the only part reported by the press. This needs to be included in the budget when getting a new computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

Moved to the Photoshop Elements forum, from the Photoshop forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

LATEST

Items of 2018 are not 64 bit. So since adobe does no updates to elements versions after the new version s realeased (yearly) this was never fixed. 

On Calatina or newer, only versions 2020 and 2021 of Elements will work. 

So if you want to use elements on MacOS >catalina, then yes you have to buy new (or look for software that is better supported than elements. For only editing, i would have switched already. )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines