Elements 2022 on macOS 12 Monterey question about Save As:

New Here ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

Hello, I have used Elements since V3 (and numerous other Photoshop programs since early '90s). I just moved from Elements 2018 to 2022 and am stumped by the Save As dialog box behavior. Hopefully I can describe this issue I am seeing:

 

I am running on macOS 12 Monterey (which has it's own baggage) and have never used Elements Organizer and attempt to disable all connections to it as I have a decades old file organization

 

Lets assume for example that I want to save in format Photoshop
Save As: <provide a filename>

Then I alter the image and want to save another version of it
Problem occurs with the Save As: dialog box

I used to simply highlight .<extension> and then overtype it and let Elements add the .psd suffix during the save.

 

This is not currently working. If I select and overtype the '.' and/or the '.<extension> Elements lets you type 1 character then immediately appends the extension, creating gibberish

- Save As: Untitled-1.psd
- select '.psd' and attempt to enter '_Ver2' and you will get 'Untitled-1_.psdVers2'

 

If that description made sense, is there a way to defeat this behavior? I don't remember this happening in any Elements 2018 or older or CS6.

thanks for any insights

TOPICS
How to , Mac , Problem or error

Views

88

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 12, 2022 Jan 12, 2022
Have you updated to Monterey 12.1, which i believe has a fix for the issue you describe.

Likes

Translate

Translate
Adobe Community Professional ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Have you updated to Monterey 12.1, which i believe has a fix for the issue you describe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

LATEST

Thank you Jeff for the quick reply! I'm not an early adopter but upgraded to 12.1 this morning, and that has resolved my issue. Imagine a release correcting something...  Time will tell what it broke.

 

But thank you again, that has been bugging me since Christmas!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines