• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Every time I open a photo in Elements I need to wait several seconds (10- 15 seconds - sometimes mor

New Here ,
Jan 14, 2023 Jan 14, 2023

Copy link to clipboard

Copied

Every time I open a photo in Elements I need to wait several seconds (10- 15 seconds - sometimes more) before the program will let me start working on the photo.

This also happens when I am editing the photo. Something is delaying the program in the back ground but I do not know what it is. Can eny one help me. I am using Eliments 2020.

thank you.

TOPICS
Performance , Problem or error

Views

56

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 14, 2023 Jan 14, 2023

Copy link to clipboard

Copied

LATEST

What OS are you using?  If you are using Windows, do you have a wi-fi printer?  If so, try changing the default printer in Windows settings.  You can change it to a PDF printer such as Microsoft print to PDF.  

 

If that is not the problem, has this just started happening?  How large is your catalog? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines