Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Help, My eraser tool is painting

New Here ,
Aug 21, 2010 Aug 21, 2010

Copy link to clipboard

Copied

When I select my basic eraser tool, it paints instead of erasing.  I was playing around with the background eraser one night and it has been messed up ever since.  I have tried resetting my tools with no luck.  I'm new to elements and I'm sure it is something simple but I just can'y figure it out.  I need it back in a hurry to finish a project.  Can anyone help?

TOPICS
Problem or error

Views

74.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 21, 2010 Aug 21, 2010

Copy link to clipboard

Copied

If you use the regular eraser on a background layer (as opposed to a regular layer) it replaces what you erase with the background color. Does it work the way you want if you first double click the background layer to change it to a regular layer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2018 Jan 14, 2018

Copy link to clipboard

Copied

I FIGURED IT OUT EVERYBODY!!! HALLELUJAH!

When you go to background layer and you are using your eraser, actually you are 'painting out' your  background layer mistakes in white!  So your eraser tool actually becomes like a paintbrush!  Simply make sure that BOTH your color boxes in the upper right hand corner are designated as pure white.  Then when you hit the eraser tool (which actually is acting like a paintbrush) your 'mistake lines' will be 'whited out' like if using good ol' fashioned 'white out'.

Probably what happened to you is that you, at one point, saw that there were some black lines on your background layer that you wanted to touch up, so you selected the paintbrush tool and chose the color black.  Once black was your designated color in one of your color boxes up in the righthand corner of the screen, everything from thereon in turned black including the eraser tool.

Took me HOURS to figure this out!  Such a simple fix it is mind-blowing!  Just choose white and 'erase away'.  Smile and press on!

All the best to you in your new project!

-Gloria

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2020 Jul 10, 2020

Copy link to clipboard

Copied

Hi: I don't see the two color boxes in the upper right hand corner that you describe. Not sure where they are. Could you be more specific as to their precise location? I'm having the problem you describe. Thanks. LGracey

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 13, 2020 Jul 13, 2020

Copy link to clipboard

Copied

thanks dude

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Thank you!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 21, 2018 Aug 21, 2018

Copy link to clipboard

Copied

This happens when the layer that you are attempting to apply the eraser is not converted to smart object.

I had the same issue a few minutes ago, this is what I did to have the eraser 'erase' instead of paint:
- Right-Click on the Background Layer
- Convert to Smart Object
- Rasterize
- Erase to your heart's content.

I hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 22, 2019 Apr 22, 2019

Copy link to clipboard

Copied

Try turning off 'erase to history' .. that fixed it for me.eraser.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2019 Apr 22, 2019

Copy link to clipboard

Copied

@Young Don, thanks for trying to help, but this is a Photoshop Elements forum.  The solution you have provided is for a control that only exists in Photoshop CC. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

He actually help with my problem, i was so annoying, his coment was so useful 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

LATEST

TTTTTTTTHHHHHHHHHXXXXXXXXXXXXXXXXXX <3<3<3<3<3<3<3<3<3<3<3<3

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

I just had the same problem: clicked to erase, and instead a black line was painted, instead of erasing part of my layer, leaving a transparent hole where I clicked. What others suggested below (changing background colour), did not solve the issue.

 

Using "ctrl + z" a few times had my eraser working correctly again, which was hurting my head until I finally realized what I did: accidentally pressed "/" instead of "l", while meaning to toggle between eraser tool and for lasso tool.

 

VOILA! Fixed. So if your eraser tool goes from erasing to painting, try pressing forward slash "/".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines