Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How to bypass the Welcome Screen in PSE 2021 on Mac

New Here ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

The PSE 2021 folder contains another folder labeled "Support Files." In it you will find Adobe Photoshop Editor. Drag that to your Dock, or double-click it, and you're in business. Thanks, Adobe, for making it simple to avoid the Welcome Screen. – Grandpa Grammar.

TOPICS
How to

Views

279

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

I found mine here -- C:\Program Files\Adobe\Photoshop Elements 2021\PhotoshopElementsEditor.exe.  But thanks for the idea that got me looking!
Now if I could just figure out how to make it not take forever to load ....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

Hi John,

 

I have PSE 2020. When I drag and drop a photo on the Editor shortcut on my desktop, it takes at the most 3 seconds to load with the photo. How long is yours taking?

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

On my Mac, PSE 2020 takes 16 seconds to start up and abiut 3 seconds to load a jpeg file. — Bob

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

I was refering to the time between when the icon is clicked and the program presents a menu. On my machine, (Intel i5 32GHz w/32GB memory, all SSD/M2 drives)  it consistently takes 5 minutes. I don't know why it takes so long, according to task manager it's hardly using any CPU, disk, or network resources.  The only thing I can think of is it's trying to communicate with Adobe servers.

Nothing else on this computer runs so slow. I recently built this tower server and every other program I run loads and runs noticibly faster. But Adobe Photoshop 2021 still continues it's age old practice of taking forever to load.  It has always been this way for me, if I need to do photo editing, I click on Photoshop and then find something else to do for a bit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

On this Mac, POE takes longer to start the Welcome Screen than it does to load the Editor directly. However, I just installed a new GPU card, and all graphics apps seem to load more rapidly. I’ll time POE on some of my other Macs and see how they do. I’m surprised that it takes so long with your SSD. (I wish I had one.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

Hi John,

 

Obviously you shouldn't have to be waiting 5 minutes for the Photoshop Elements Editor to open! 🙂

 

On the loading screen does it get stuck on the Starting-up plugins... part?

 

If so, go to Help > System Info... then scroll down towards the bottom of the information presented in the dialog box until you get to the section called Plug-ins that failed to load. Take a note of the plug-in(s) that failed to load and uninstall them from your system. That should solve your start-up issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

Well .. that was odd. We had a momentary power outage so my computer shut down.  When it came back up, Photoshop Elements Editor started up in just 3-4 seconds.  I just installed it a few days ago  as I just built a new computer and decided that I got my money's worth of the 11 year old version I already had. So maybe it just needed a restart??

 

I dunno...I guess next time it's slow I'll just reboot. 🙂

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

Good news. I hope that continues to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

John,

 

I also build my own PCs. When things are not working right, restarting frequently takes care of it. What harm is done by restarting your PC every few days or at least once a week? It should be a part of PC routine maintenance.

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

As a 40 year IT professional, my personal opinion is that servers needing rebooting on a regular basis usually have an issue that constant rebooting only masks.  My experience has been that it is better to find out why one needs to reboot and fix it once rather than put reboots on a schedule.  In this particular instance, Adobe may have a poor installation process that fails to identify on startup that a reboot is needed to complete the installation process and alert the user.  If that is the case, that's just sloppy programming. Or there may have been some other issue completely unrelated.  The complete lack of resource usage seems to indicate some sort of wait state which tends to make me believe it was Adobe trying to connect to some network resource and was unable to do so.  I was considering installing a firewall service on my computer to try and diagnose it, but fate intervened.

I'll never know now unless it returns because I can't diagnose it because it no longer occurs. If the slow performance never returns, the actual root cause will remain unknown.

Finding the root cause and correcting it is usually the better solution than rebooting but depends on technical skills and deciding if it's worth the time and effort. I'll admit that from time to time, rebooting did temporarily resolve an issue. But in the cases I can remember, it was usually due to a production level problem that needed to be remediated right away and it was determined to put off root cause analysis for the sake of availability.  Or an "I can't figure it out, reboot and see if it goes away" decision.  I'll also admit that I am not a Windows technician and am better suited for finding issues in Unix servers than Windows PCs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

@JohnF21, another possibility for your slow startup is that the Organizer is analyzing your media for face recognition and smart tags etc.  In theory, the media analysis only takes place when nothing else is happening on your machine.  But as Yoggi Barra said: In theory there is no difference between theory and practice.  In practice there is.  So if the media analysis is chugging away before you launch the Editor, there can be a delay.  The fact that you were able to launch quickly after rebooting could mean that the media analyis had not yet started before you launched the program.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

LATEST

If that were the case, I would have expected to see disk and CPU usage. As I noted above, there was no appreciably CPU, Disk, or network usage when this was occuring. I will keep that in mind though and make sure organizer is disabled, I have my own processes for organizing my media and don't need any help. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines