Mac support for Photoshop Elements 13

Contributor ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

What newer operating system on Mac will still support Elements 13?  I have a friend who is hesitant to use a newer version of Elements but needs to upgrade a MacBook Pro which is currently running El Capitan!

 

Mary Lou

 

 

TOPICS
Mac, Performance

Views

58

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Nov 04, 2021 Nov 04, 2021
MacOS Mojave 10.14 is the last version that could support pse 13 since some of it's included utilities are 32 bit.

Likes

Translate

Translate
Adobe Community Professional , Nov 12, 2021 Nov 12, 2021
Starting with macOS Catalina 10.15 Apple removed the ability to run 32 bit applications, so Mojave 10.14 and older will still run 32 bit applications. Even though pse 13 itself is 64 bit, some of the included utilities like the updater are 32 bit, so Catalina and newer will refuse to install pse 13. https://support.apple.com/en-us/HT208436

Likes

Translate

Translate
Adobe Community Professional ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

MacOS Mojave 10.14 is the last version that could support pse 13 since some of it's included utilities are 32 bit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Thanks so much, thast is the exact inforation I needed!

 

Mary

quote

MacOS Mojave 10.14 is the last version that could support pse 13 since some of it's included utilities are 32 bit.


By @Jeff Arola


Lou

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Are you saying that 32 bit is new at Mojave or after Mojave?  If so then perhaps he should stop at High Sierra?  I will check to see if his laptop includes 32 bit.

 

Mary Lou

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Starting with macOS Catalina 10.15 Apple removed the ability to run 32 bit applications, so Mojave 10.14 and older will still run 32 bit applications. Even though pse 13 itself is 64 bit, some of the included utilities like the updater are 32 bit, so Catalina and newer will refuse to install pse 13.

 

https://support.apple.com/en-us/HT208436

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

LATEST
Thank you for this clarification. I am now better informed.

Mary Lou

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines