• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Obtaining older versions of Elements

Explorer ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

I have purchased in the past Version 18 and now 23. I recently reinstalled Catalina on my Mac and neither of those versions are compatible. Surely I don't have to purchase an older compatible version...Help Please!

TOPICS
Download and install , How to , Mac

Views

372

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

quote

I have purchased in the past Version 18 and now 23.

 

Can you clarify those version numbers?

 

Recent versions include:

 

Photoshop Elements 2023 (version 21.0) - compatible with Big Sur, Monterey, Ventura 

Photoshop Elements 2022 (version 20.0) - compatible with Catalina, Big Sur, Monterey

Photoshop Elements 2021 (version 19.0) - compatible with Mojave, Catalina, Big Sur

Photoshop Elements 2020 (version 18.0) - compatible with High Sierra, Mojave, Catalina 


Based on your post, Elements 2020 (version 18.0) should run on Catalina.

 

Have you tried installing 2020? If so, what issues or error messages have you encountered?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

John,

I have 18 and I have 23.  I just purchased a refurbished 2014 mac mini and installed Catalina. 23 won't work with it and I tried to download a version of 18 only to be messaged on install that it was not compatible??? 

Thanks for your assistence!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

Perhaps I should add that I'm running Catalina 10.15.7. I believe that was the issue. I've chosen this configuration because I do a lot of Audio Recording and it's a very stable OS. I do not was to upgrade the OS for this reason. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

quote

a version of 18 only to be messaged on install that it was not compatible??? 

 

Is that Elements 2018? or Elements 2020 (version 18)?

 

Should be no issues with Elements 2020 on Catalina.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

quote

I have 18 and I have 23.

 

Sorry @RoylPain. Still unclear which versions those are.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

Sorry,

It's 2018 and 2023 that I have previously purchased. Surly I can get an older version that will work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

OK. Unfortunately both are unsupported on Catalina.

 

You'd probably have to downgrade your Mac to High Sierra to get Elements 2018 installed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 06, 2023 Oct 06, 2023

Copy link to clipboard

Copied

So Adobe won't give me an older version that is compatible with my OS?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 06, 2023 Oct 06, 2023

Copy link to clipboard

Copied

No.

 

The only version they now sell is 2023. Version 2024 is imminent. When that is released, they'll stop selling 2023 pretty much the same day.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 06, 2023 Oct 06, 2023

Copy link to clipboard

Copied

LATEST

Someone really need to offer some competition for Adobe so we aren't shackled to this kind of BS!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2023 Oct 05, 2023

Copy link to clipboard

Copied

Is that photoshop elements 2018 and photoshop elements 2023?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 06, 2023 Oct 06, 2023

Copy link to clipboard

Copied

Yes.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines