Organizer seems to be stuck on Import screen

Explorer ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

I'm using PSE Organizer 2018 (version 16) with Win 10.   Instead of opening with a grid of my photos, it opens at an Import screen and I can't seem to find a way to dismiss that  and go to the photos already in the organizer.       Could someone please tell me how to escape if I don't want to import anything new?

Thanks so much!

TOPICS
How to , Organizer

Views

55

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 08, 2022 Jul 08, 2022

A picture (screenshot) would be worth a thousand words.   I have never seen the problem you are describing. If you click on the Import dropdown, clicking anywhere else on the screen should close it.

Snap_2022.07.08_18h8m53s_004.png

 

Do you have taskbar settings set to autohide.  Depending on your monitor size, this can cause an issue with menu operation.  If so, turn autohide taskbar off.

 

The only other possibility I can think of is that you have filtered out the media from your catalog. Go to the View>Media Types menu and

...

Likes

Translate

Translate
Explorer ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Perhaps I should explain what I can see.  Top left corner is Import with a drop down list (but exit Import is not an option on that list), in the top middle of the window is eLive, Media, People, Places, Events and top right is Create and Share with their respective drop down lists.   Above all that is the usual File, Edit Find View and Help menus but again, there is no "take me back to the photos already in the organizer".    I can change catalogs but it just offers a differe  nt selection of images to Import.      I hope this description helps someone to identify a solution.   I'd really like to be able to access the photos already in there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

A picture (screenshot) would be worth a thousand words.   I have never seen the problem you are describing. If you click on the Import dropdown, clicking anywhere else on the screen should close it.

Snap_2022.07.08_18h8m53s_004.png

 

Do you have taskbar settings set to autohide.  Depending on your monitor size, this can cause an issue with menu operation.  If so, turn autohide taskbar off.

 

The only other possibility I can think of is that you have filtered out the media from your catalog. Go to the View>Media Types menu and make sure that all of the options are checked.  (Or press Ctrl+1 etc. to toggle the media on or off.)

Snap_2022.07.08_18h18m26s_005.png

 

If none of these suggestions work, please post a screenshot of what you are seeing.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 09, 2022 Jul 09, 2022

Copy link to clipboard

Copied

Thank you so much for taking the time to reply!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 09, 2022 Jul 09, 2022

Copy link to clipboard

Copied

LATEST

@imaquila can you let us know which of the solutions worked for you.  It may help others who run into the same problem.  Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines