• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Photoshop Elements 2018 needs install updated for Catalina

New Here ,
Oct 05, 2022 Oct 05, 2022

Copy link to clipboard

Copied

I received and error message when I installed Adobe Photoshop Elements 2018 to my laptop. I use this on my iMac Desktop and have no problem.

How do I find the install update? 

Screen Shot 2022-10-05 at 11.51.09 PM.png

TOPICS
Problem or error

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 10, 2022 Oct 10, 2022

Elements 2018 will probably not work well, if at all, with Catalina.  See this article.

Likes

Translate

Translate
Community Expert ,
Oct 10, 2022 Oct 10, 2022

Copy link to clipboard

Copied

Elements 2018 will probably not work well, if at all, with Catalina.  See this article.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 10, 2022 Oct 10, 2022

Copy link to clipboard

Copied

Thanks for your reply.
I did have to upgrade to Elements 2022 and it is working fine now.
I had great help from Adobe Support.
Thanks again for your information.
Take care

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

Did you have to pay for Elements 2022? I am having the same problem but adobe support is not offering any help. Instead they told me it's Apple's fault for not wanting older versions of the software to work. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

1. Yes you have to pay

2. Yes, Apple did deliberately block all old apps to force us all to upgrade. It's all part of the Joy of Mac. You can't seriously expect to get the latest app for free when you choose to upgrade your system... this needs to be in your budget. 
But check if the latest Photoshop Elements even runs on the old Catalina system. Photoshop CC does not. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

LATEST

Update: https://helpx.adobe.com/uk/photoshop-elements/system-requirements.html says no. If you upgrade to the old Catalina you are stuck; nothing is available to you. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines