Photoshop Elements 2019 Editor does not start anymore.

New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

As the title says I can not start the Fotoeditor anymore. If I click on it it starts loading and then nothing happens. It does not open. I tried a complete reinstallation without success. 

 

 

TOPICS
Crash or freeze , Problem or error , Windows

Views

95

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Ok so I tried everything that I could imagine. Updated and reinstalled drivers, reinstalled the software, uninstalled and unplugged my Wacom, Windows 10  DISM. Started it from the launcher, started it from the .exe started it in admin mode, started it in compatibility mode. Deactivated / uninstalled my anti viral software. Nothing helped.

 

It still crashes on start without any notice. It shows the starting and Initialisation then it closes. 

Screenshot 2021-06-24 210459_2.jpg

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

I Have a very similar issue... I had been using Photoshop Elements 15 with no problems. Last graphic I made using it was New Years Eve...  Ihad a new graphic to start and suddenly it won't open.  I click on the lancher and I get an immediate error message

 

"The application was unable to start correctly (0xc000007b), Click OKto close the application"

 

I tried uninstalling enything that I installed AFTER installing Photoshop Elements 15. Nothing changed. So I uninstalled photoshop and reinstalled it.  NOPE, same error message.

 

Sadly Adobe makes it difficult to get any assistence. I sure wish there was a way to actually get some tech support.

 

System

Asrock 399X motherboard

AMD 1920X Threadriper 12 core processor

64Gb Oloy RAM

3 Samsung M.2 SSDAMD FirePro W2100 graphics

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2022 Jan 08, 2022

Copy link to clipboard

Copied

Try to delete the programm, then go to the applications folder and also remove all  files that are left after the removal ( like for example plugins and so on) Then reinstall. 

 

In my case it turned out to be a plugin that was not useable anymore and cause the  appliation to crash on start.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2022 Jan 08, 2022

Copy link to clipboard

Copied

LATEST

Thanks, and yes, I already did that, and I get the same result... That same error message.

 

I suspect that the latest Windows 10 update may have had something to do with it. I am going to also pot on the windows 10 pages and see if Microsoft has an answer.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines