Photoshop Elements 2020 - crashes and/or refuses to upload photos macOS Catlina

New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

Hi

I am running Elements 2020 on a mid 2015 IMac, version 10.15.7 on Mac OS Catalina.

Initially the organiser and/or photo downloader consistently crashed either before or during uploading photos from a compact flash card.

Things then got progressively worse eg I could eventually download the photos to the computer but it then stopped deleting the photos from the CF card eg it crashed at that point meaning I have to manually delete the photos (dont want to format card as some past photos I want to retain on it).

Now I am having difficulty with the photo downloader even detecting the CF card eg it says "no device found".

Any pointers gratefully received as this Adobe software is driving me slowly demented...

Thanks

Richard

 

{Title edited by Moderator}

TOPICS
Crash or freeze , Mac , Problem or error

Views

55

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

Hi Richard,

 

Sorry about the trouble with Photoshop elements 2020. We're here to help.

Would you mind updating your operating system and the application to the latest version? Did you try re-installing the application? Since when are you seeing this crash issue? 

Is there any background application that runs with Adobe Photoshop Elements?
Please try saving the images in your internal drive rather than importing them to Elements directly from the external device? Let us know how it goes.

 

Please check this article for a few troubleshooting steps: https://helpx.adobe.com/photoshop-elements/kb/troubleshoot-system-errors-freezes-photoshop.html.

 

Let us know if it helps.

 

Thanks.

Ranjisha

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

LATEST

the os requirements say 10.15, not 10.15.7.   That's probably your issue. 

Buy a chip reader, your issue will probably go away. chip reaDER.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines