Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop Elements 2021 installed from the Microsoft Store

Guest
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

With the Organizer there is no problem. Everything works correctly.

 

But the Photo Editor when I select it on the initial screen, the program starts fast, but I can't do anything, nor select any menu until after 40 seconds. The program is inoperative during these 40 seconds.

 

After these 40 seconds everything works normally and without delays.

 

The computer is a Microsoft Surface i7 16GB RAM. Windows 10 Home. Everything up to date. Everything is running very smoothly.

 

Does anyone know of a solution?

 

TOPICS
Crash or freeze, Performance, Problem or error, Windows

Views

107

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Hi,

 

To start troubleshooting this issue, can you initially start up the Photo Editor while you're not connected to the internet and see if the delay disappears.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Hi, Phil DC.

 

Thank you for your assistance.

 

Effectively. If I am not connected to the Internet, the delay disappears.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Hi,

 

That points to something blocking a network request from Photoshop Elements and causing Elements to hang until the request times out.

 

What's your network setup? Are you using a NAS device? Have you configured anything special on the router? Are you on a corporate network or at home?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

LATEST

I am not using any NAS unit.

My network configuration is standard without any modifications.

I have tested it on other networks (the one at work with wifi and ethernet wire) with the same result.

On the work computer I have installed the program (from the Microsoft Store) and it works correctly. I guess it is something specific to the Microsoft Surface.

I have tested it with the cell phone access point and the same thing happens.

The truth is that it is discouraging to use it.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines