Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop Elements 2021 shows only Elements Icon for a psd Pile, Not a Photo

New Here ,
Dec 26, 2020 Dec 26, 2020

Copy link to clipboard

Copied

I have a brand new computer with Windows 10.  I installed Elements 2021 last week. Working in Elements last week,  the PDS file showed a photo thumbnail when browsing in Photoshop Elements.  Now when I want to open a file, if it is in psd format, I see only the Elements logo, not a thumbnail of the actual photo.    There was some sort of update and I downloaded and installed 2 Topaz filters which I purchased some  time ago for my old computer.  The filters do not show in the filter gallery for 2021 .  Could either the update or the filters have changed anything?  I have 2 more filters to download and install.

I also have Elements 7 and the Filter Gallery there shows the filter.

I Hope this is not too confusing.  The Adobe Help could not seem to get what I was saying.  She finally said no one was there and to go to the Forum

I have:

C>ProgramFiles (x86)>Adobe>PhotoshopElements 7.0   and 

 C>Prog. Files (x86)>Topaz labs>Topaz Adjust and Topaz Fusion Express

 

C>ProgFiles>Adobe>Photoshop Elements 2021   

and    C>ProgFiles>Topaz Filters>Topaz Simplify 4

 

TOPICS
Problem or error

Views

140

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 26, 2020 Dec 26, 2020

Copy link to clipboard

Copied

Working in Elements last week, the PDS file showed a photo thumbnail when browsing in Photoshop Elements. Now when I want to open a file, if it is in psd format, I see only the Elements logo, not a thumbnail of the actual photo.

 

Does the Elements logo that you see look like this:

Ashampoo_Snap_2020.12.26_15h57m24s_002_.png

If so, that means that the file thumbnail has not yet been updated in your new 2021 catalog.  If you have a large catalog, rebuilding the thumbnails can take a long time.  Have you tried updating the thumbnail manually, using either the Edit>Update Thumbnail menu or the Ctrl+Shift+U keyboard command? 

If you mean a different generic logo, please give us a screenshot.

 

There was some sort of update and I downloaded and installed 2 Topaz filters which I purchased some time ago for my old computer.

 

Are you saying that you received an update to the Topaz filters?  I think Topaz updated my old Adjust filter to the new one for free when they introduced Topaz Studio last year.  If so, the Topaz installer does not seem to install automatically into Elements 2021.  Therefore, look for a file with topaz[filter name] in the name and with a file extension of .8bf and copy it to the following folder location:

C:\Program Files\Adobe\Photoshop Elements 2021\Plug-Ins. 

For example, if you have the Topaz Adjust AI filter the plugin file is called tltopazadjustaips_x64.8bf

 

If you have the older Adjust filter that worked in your Elements 7, then that filter probably doesn't work with Elements 2021 because it is a 32 bit file and Elements plugins now need to be 64 bit.  

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

 Like this

Martha110_1-1609117727531.png

I think that it might have been one of the lagacy filters-several were.  I have not tried to go back to Topaz Labs until I cleared up these other issues.

I also right-clicked on my Elements workspace and made it a lighter grey.  Now it is dark again and I cannot change it.

I can't make the layers panel dock under the History panel either.  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

I meant Legacy filter.    And thank you for your reply

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

@Martha110 

...the PDS file showed a photo thumbnail when browsing in Photoshop Elements.

You mean the .psd Photoshop format? Then it's a Microsoft issue: this image format can no longer be displayed in the Windows Explorer without an external 'codec' to read this format. When you are navigating in your computer to open a file in the Photoshop Elements editor, you ae in the Explorer. There are external utilities you can install to make the Explorer display the thumbnails instead of generic ones, but you don't need to if you use the Organizer to import and browse your files.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

When I want to open a photo in Elements that I have saved as a psd, it shows this instead of the thumbnail of the actual photo.  I  will check and see what happens in Elements 7 but last week it showed correctly. 

It's been frustrating because of all the changes (from 7 to 2021).  Also a new computer with Windows 10 and (and going from Word 2003 to 2020). A lot of new stuff to learn!

Thank both of  you for the reply

Martha110_0-1609118191140.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

When I want to open a photo in Elements that I have saved as a psd, it shows this instead of the thumbnail of the actual photo.

As Michel says, the issue of the PSD generic icon showing instead of the photo thumbnail belongs to the OS.  As he also states, there are a number of utilities (some free) that can be used to show a thumbnail for PSD files in Win 10. 

However, IMO, you are better off using the Organizer to manage and view your files.  PSD files show up with thumbnails which you can view at full screen level.  Select a file in the Organizer, press Ctrl+I and it will open in the Elements Editor.

 

I also right-clicked on my Elements workspace and made it a lighter grey. Now it is dark again and I cannot change it.

You have to have an image open in the Editor in order to change the color of the workspace.  If that is not working, try resetting the preferences file. Go to Edit>Preferences>General tab and click the Reset Preferences on next launch button.  The color will be taken back to the default and hopefully you can change the color again.

 

I can't make the layers panel dock under the History panel either.

Click on the tiny arrow next to the More button in the lower right corner of the screen.  This will open a context menu and you can choose Custom Workspace.  You will then be able to dock the Layers panel under the History panel.

 

Ashampoo_Snap_2020.12.27_18h31m11s_000_SnapCollage.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

LATEST

Thank you so much. I have pre-ordered a book on Elements 2021 (2nd edition book)  and this should be a big help.  Meanwhile I'll try the Organizer.  In previous Elements, the Organizer was constantly having problems so I quit trying to use it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines