Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


printer incompatibility

New Here ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

I have just changed to a canon selphy cp1300 ws after my canon selphy cp 910 packed up. When I try printing I get the message 'printer not compatible with elements 15'!  How can I correct this please?

TOPICS
How to, Problem or error

Views

89

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 05, 2021 Apr 05, 2021
1. Go on Canon's web site and make sure that you have the latest driver for the new printer. 2. In Editor, go to Edit>Preferences>General. Click on "reset preferences on next launch" and proceed to do this. Close PSE and restart the program.

Likes

Translate

Translate
Adobe Community Professional ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

LATEST

1. Go on Canon's web site and make sure that you have the latest driver for the new printer.

2. In Editor, go to Edit>Preferences>General. Click on "reset preferences on next launch" and proceed to do this. Close PSE and restart the program.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines