• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Unable to print from 2020 or 2022 after recent OS update

New Here ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard


Adobe Tech

Elements 2020 & Elements 2022 have both failed to print after Big Sur update from OS 11.6.1 to 11.6.2 on iMac. Epson printer SC P800, driver V10.85 latest.. Have tried resetting all printer settings and installing usb print driver again. Have reset computer permissions, given hard drive repair, all without success. After trying to print the editor freezes, and force quit has to be used ? Have also tried re-installing 2020 that originally printed but failed to print ?

Strangely I am able to print from both Affinity Photo, and Capture One Pro 2022 without a problem ?

This is serious and needs to be fixed guys. Have been using Elements since version 2..

Apple suggested in a popup work around to use Airprint, unfortunately there is no ability to set profiles or other setttings for a high end print. App is un useable if I cannot print from it ! Your help in resolving this would be appreciated,

Kevin James







Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation