'Validate' button asks to connect to internet when I'm on-line

New Here ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

Hello,

 

I've installed Adobe Photoshop Elements 12 on my new computer.  It says that if I don't validate it today it will stop working.  I jumped through all the hoops and then saw a box on my screen saying "Serial Number Validation".  There are two buttons: 'connect later' and 'validate'.  When I click 'validate', it says "Please connect to the internet to validate your serial number".  I am definitely connected, as this post proves.  Any ideas?  

 

Lloyd

TOPICS
Download and install , Problem or error

Views

97

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

See if any of the solutions in this HelpX Article help you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

Thanks for the reply.  The link was about other products, and my specific problem was not addressed.  I am definitely on the internet, else I would not be able to post this.  I installed the software from physical discs I own.  I see that some products may be used on two computers maximum.  Might this apply to Photoshop Elements 12?  I wouldn't have thought so.  Besides, that's not what it is saying - it is asking me to connect to the internet when I already am, and it leaves me there stranded.  I think I've run out of time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

LATEST

The issue is that the "backroom" software that validates PSE version 12 was basically turned off years ago-- really no reason to keep validating (or supporting) such older versions.


GO HERE:  Contact Customer Care (adobe.com)

CLICK ONTHE SPEECH BUBBLE IN THE BOTTOM RIGHT CORNER- IT HAS 3 DOTS IN IT.

An autoresponder kicks in and asks "what do you help with" (or something close to that)  type in AGENT
 and wait. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines