Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Why do I get a "no pixels selected" when making adjustments in a new layer?

New Here ,
Jun 08, 2010 Jun 08, 2010

Copy link to clipboard

Copied

What am I doing wrong?  I want to modify or replace the color in a selection, so I make the selection, create a new layer, and try to replace the color from the Enhance menu.  I get the message " can't do it because no pixels are selected."  The selection is OK; I can see the marching ants.  The same happens when I try other color adjustments and probably other adjustments as well.  Would appreciate some help.  Many thanks.

TOPICS
Feature request

Views

50.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 08, 2010 Jun 08, 2010

Copy link to clipboard

Copied

Try turning off visibility of layers you are not working on. I think this should help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 08, 2010 Jun 08, 2010

Copy link to clipboard

Copied

Sounds like you have an empty layer selected.

Even if you have a selection established (showing the marching ants), your creation of a New Layer means that your selection is now on that new layer, which is empty, and thus there are no pixels selected to modify.

Try skipping the New Layer step.

Or, duplicate the layer you want to work on, then do the selection, then the adjustment.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2015 Oct 16, 2015

Copy link to clipboard

Copied

on the toolbar. set your feather to "0"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2018 Apr 19, 2018

Copy link to clipboard

Copied

It worked! Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2019 Feb 07, 2019

Copy link to clipboard

Copied

Check to see if the layer is locked, and click to unlock it. Also, make sure that the feather setting is not too high for the size of the selection.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Thanks so much! I didn't even pay any attention to the feather selection! This worked for me!!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

LATEST

Yes, that was my problem. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2019 Aug 14, 2019

Copy link to clipboard

Copied

I had this same problem for months.  I found that I had to do several things:  put a copy of the photo from which I want to copy into the same tab as the target photo.   Secondly, make sure "Add to Selection"  chosen at the bottom for the Magic Wand.  If you have "Intersect wtih Selection" or another option chosen, it will give you the error message.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines