Worked the first time in Monterey but now sign in problem

New Here ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

I have read about the compatability issues of Elements 20 and Monterey. However, it opened & worked yesterday. There were no computer updates since then. Today I just keep getting the Adobe sign in screens over & over, even though it accepts my info as correct.  Is this a sign in issue?
When I sign into my Adobe account, it does not show any active devices (the old or new Mac) & I do not get the "Manage Plans" option, although it shows the current version version of elements under "Your Product."
Of course, Elements still works on old Mac, but I don't understand why it worked yesterday & not today.

TOPICS
Mac , Problem or error

Views

26

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2022 May 26, 2022

Copy link to clipboard

Copied

LATEST

Try contacting Elements support. You can start a chat session by clicking on the blue Contact Us button under the Help & Support menu at Adobe.com. Or you can contact Support by telephone using the numbers listed here: https://helpx.adobe.com/contact/phone.html.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines