Highlighted

2019 Elements Organizer maps not showing

New Here ,
Oct 06, 2019

Copy link to clipboard

Copied

Map is not showing when looking at existing photos with locations or searching for new location.   I was forced to upgrade to 2019 version this year due to problems with maps, now it appears like same problem.   Maps worked fine for me a month or so ago.   Today no map, search for location does nothing, no errors.  Got latest updates for version 2019, same results.   Anyone else experience this?

Views

90

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2019 Elements Organizer maps not showing

New Here ,
Oct 06, 2019

Copy link to clipboard

Copied

Map is not showing when looking at existing photos with locations or searching for new location.   I was forced to upgrade to 2019 version this year due to problems with maps, now it appears like same problem.   Maps worked fine for me a month or so ago.   Today no map, search for location does nothing, no errors.  Got latest updates for version 2019, same results.   Anyone else experience this?

Views

91

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 06, 2019 0
Adobe Employee ,
Oct 11, 2019

Copy link to clipboard

Copied

Hi,

 

  • Are you connected to the internet?
  • Please check your Country/Region in Organizer Preferences. Preferences can be accessed using Ctrl+K keys. (Cmd+K in mac)

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 11, 2019 0
New Here ,
Oct 13, 2019

Copy link to clipboard

Copied

Yes.  Internet connection was good then and now.  Setting are good. This working on same PC, internet, and settings for 6-7 months.   Behavior is exactly like when my previous version stopped working on 11/2018 - supposedly due to google maps change in api.   Tried multiple times.  Always able to access anything online and find same location via google maps in browser.  Tried searching gor 20+ locations as well.  Always blank map and no result from search.  No errors anywhere on the UI.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0
New Here ,
Oct 28, 2019

Copy link to clipboard

Copied

I replied with the answers 10/13/2019.   Any updates?   

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2019 0
New Here ,
Dec 19, 2019

Copy link to clipboard

Copied

Still have same problem.   I responded to question on this, then responded again.  Why no updates?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2019 0
New Here ,
Dec 20, 2019

Copy link to clipboard

Copied

Found solution.   Maps do not work with laptop in docking station or connected to external monitor.  Maps work fine when laptop is on its own.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2019 0