Highlighted

Adobe Elements 10 Organizer

New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Hello

With now macOS Catalina I cannot open Adobe Elements 10 Organizer

What should I do?

Thanks.

Version : 10.0.(20110831.m.17215)

  Obtenues de : Inconnu

  Dernière modification : 24/10/2016 08:50

  Emplacement : /Applications/Adobe Elements 10 Organizer.app

  Type : 32 bits (non pris en charge)

  Informations générales : 10.0, Copyright � 1990-2009 Adobe Systems Incorporated

TOPICS
How to

Views

105

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe Elements 10 Organizer

New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Hello

With now macOS Catalina I cannot open Adobe Elements 10 Organizer

What should I do?

Thanks.

Version : 10.0.(20110831.m.17215)

  Obtenues de : Inconnu

  Dernière modification : 24/10/2016 08:50

  Emplacement : /Applications/Adobe Elements 10 Organizer.app

  Type : 32 bits (non pris en charge)

  Informations générales : 10.0, Copyright � 1990-2009 Adobe Systems Incorporated

TOPICS
How to

Views

106

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 06, 2020 0
Adobe Employee ,
Jan 07, 2020

Copy link to clipboard

Copied

Hi there,

 

Photoshop Elements 10 is not supported on MacOS Catalina. Below are the system requirements for Photoshop Elements 10:

 

WINDOWS
1.6 GHz or faster processor (including single-core support)
Microsoft® Windows® XP SP3, Windows Vista®, or Windows 7
1 GB of RAM (2 GB for HD video functions)
4 GB of available hard-disk space (additional free space required during installation)
Color monitor with 16-bit color video card
1024 × 576 display resolution
Microsoft DirectX 9 compatible display driver
DVD-ROM drive
Internet connection required for Internet-based services


MAC OS
Multicore Intel® processor
Mac OS X v10.5.8 through v10.7
1 GB of RAM (2 GB for HD video functions)
4 GB of available hard-disk space (additional free space required during installation)
1024 × 768 display resolution
DVD-ROM drive
QuickTime 7 software required for multimedia features
Internet connection required for Internet-based services

 

Thanks,

Akash

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 07, 2020 1
Adobe Community Professional ,
Jan 07, 2020

Copy link to clipboard

Copied

>> What should I do?

 

Upgrade to Elements 2020 which is compatible with Catalina.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 07, 2020 0
New Here ,
Jan 07, 2020

Copy link to clipboard

Copied

Hello
Adobe Elements 10 Organizer does not work anymore.
What should I do?
Best.
Francis Ruleta

Version : 10.0.(20110831.m.17215)
Obtenues de : Inconnu
Dernière modification : 24/10/2016 08:50
Emplacement : /Applications/Adobe Elements 10 Organizer.app
Type : 32 bits (non pris en charge)
Informations générales : 10.0, Copyright � 1990-2009 Adobe Systems Incorporated

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 07, 2020 0
Adobe Community Professional ,
Jan 07, 2020

Copy link to clipboard

Copied

>> Adobe Elements 10 Organizer does not work anymore.

 

Refer my previous response: 

 

"Upgrade to Elements 2020 which is compatible with Catalina."

 

Likes

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 07, 2020 0
New Here ,
Jan 14, 2020

Copy link to clipboard

Copied

Sorry but totally wrong. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2020 0
Adobe Community Professional ,
Jan 14, 2020

Copy link to clipboard

Copied

You have given no indication of what you think is totally wrong.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2020 0
New Here ,
Jan 14, 2020

Copy link to clipboard

Copied

Dear John

Simply Adobe confirmed that Catalina is NOT supported by my previous PShop Elements 10 and I must purchased 20. Which I did and all is ok now.  Something you don't understand ? 
Best. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2020 0
Enthusiast ,
Jan 14, 2020

Copy link to clipboard

Copied

This ground has already been plowed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2020 0