Highlighted

Boxed Ver 13.0 Doesn't Recognize New Printer

New Here ,
Dec 27, 2019

Copy link to clipboard

Copied

Hi,

My trusty longtime WiFi-connected Epson Artisan 835 aio printer recently gasped it's last. I gave it a fond farewell at the recycling center. I purchased a brand new Epson XP-970 as a replacement because it seems the least problematic of the current generation Epsons that print nice photos. I scrubbed my PC's old Epson 835 drivers/utilities with the Revo Uninstaller Free app before loading the new printer's drivers/utilities.

The new printer prints fine for all of my PC's doc and text files as well as anything remotely printing via WiFi from phones/tablets/PCs.

Unfortunately, when I try to print existing files from Elements 13 I get an error the default printer isn't connected. The new printer is the only one in the print drop down menu. This happens with newly created files as well as old/existing files. I can't find my way to setting a default printer in Elements prefs. What am I missing?

PC is running Windows 10 64-bit with all current patches/updates applied. I don't see any obvious error messages in my Norton or Malwarebytes logs that Elements isn't permitted access through the firewall.

Ideas? I'm thinking perhaps uninstalling/reinstalling Elements 13 from it's CD, but I'm not sure whether I need to unregister my current install first. Help! 😱

Thanks to some more online research, I tried the "hold down CTRL/ALT/Shift keys" recommended while booting the current-generation Elements, reply "Yes" to "Reset Settings?", and now my old boxed Elements 13.0 prints to my new printer. Just thought I'd provide the solution here, too.

TOPICS
Problem or error, Windows

Views

29

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Boxed Ver 13.0 Doesn't Recognize New Printer

New Here ,
Dec 27, 2019

Copy link to clipboard

Copied

Hi,

My trusty longtime WiFi-connected Epson Artisan 835 aio printer recently gasped it's last. I gave it a fond farewell at the recycling center. I purchased a brand new Epson XP-970 as a replacement because it seems the least problematic of the current generation Epsons that print nice photos. I scrubbed my PC's old Epson 835 drivers/utilities with the Revo Uninstaller Free app before loading the new printer's drivers/utilities.

The new printer prints fine for all of my PC's doc and text files as well as anything remotely printing via WiFi from phones/tablets/PCs.

Unfortunately, when I try to print existing files from Elements 13 I get an error the default printer isn't connected. The new printer is the only one in the print drop down menu. This happens with newly created files as well as old/existing files. I can't find my way to setting a default printer in Elements prefs. What am I missing?

PC is running Windows 10 64-bit with all current patches/updates applied. I don't see any obvious error messages in my Norton or Malwarebytes logs that Elements isn't permitted access through the firewall.

Ideas? I'm thinking perhaps uninstalling/reinstalling Elements 13 from it's CD, but I'm not sure whether I need to unregister my current install first. Help! 😱

Thanks to some more online research, I tried the "hold down CTRL/ALT/Shift keys" recommended while booting the current-generation Elements, reply "Yes" to "Reset Settings?", and now my old boxed Elements 13.0 prints to my new printer. Just thought I'd provide the solution here, too.

TOPICS
Problem or error, Windows

Views

30

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 27, 2019 0
New Here ,
Dec 27, 2019

Copy link to clipboard

Copied

Thanks to some more online research, I tried the "hold down CTRL/ALT/Shift keys" recommended while booting the current-generation Elements, reply "Yes" to "Reset Settings?", and now my old boxed Elements 13.0 prints to my new printer. Just thought I'd provide the solution here, too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2019 0
Greg_S. LATEST
Adobe Community Professional ,
Dec 27, 2019

Copy link to clipboard

Copied

Thanks for letting us know what worked for you.  Yes, resetting the preferences file usually resolves printer issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2019 0