Highlighted

Can't install PSE on Windows 10

New Here ,
Jul 06, 2020

Copy link to clipboard

Copied

I have a very old copy of PSE, which worked fine with Windows XP. I have changed to Windows 10, and would like to re-install, but I get a message saying 'must have Internet Explorer 4 or above' and the installer shuts down. Any ideas?

TOPICS
Download and install

Views

62

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can't install PSE on Windows 10

New Here ,
Jul 06, 2020

Copy link to clipboard

Copied

I have a very old copy of PSE, which worked fine with Windows XP. I have changed to Windows 10, and would like to re-install, but I get a message saying 'must have Internet Explorer 4 or above' and the installer shuts down. Any ideas?

TOPICS
Download and install

Views

63

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 06, 2020 0
Adobe Community Professional ,
Jul 06, 2020

Copy link to clipboard

Copied

What version of Elements are you using?  It may be too old to install on Windows 10.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 0
Jon1D LATEST
New Here ,
Jul 06, 2020

Copy link to clipboard

Copied

Hello, Greg. The CD isn't very clear on this, but I think it's 1.0.1 (!)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 0