Cannot Update Photoshop Elements 2020

New Here ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

I have installed Photoshop elements 2020 from DVD on my OS 10.14 mac. The photo editor opens OK but when I go to close it says there is an update. When I try to update I get an error that no application is set to open the update. Screenshot

https://drive.google.com/open?id=16haZEyhXAM55ZwrnDb94yQisYR3zT-_4

 

I have followed the fix listed here : https://community.adobe.com/t5/photoshop-elements/cannot-update-pse-2019-osx/td-p/10401074?page=1#10... but the Adobe Update Helper app is not present on my machine.

 

Thanks

 

Andy

TOPICS
Mac, Problem or error

Views

866

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

LEGEND , Feb 14, 2020 Feb 14, 2020
Are you looking in the system library, not the user library? If you click Go on the top menu and choose go to folder it usually takes you to /Library/ and you can follow the path from there. The helper app is usually inside the HDBox folder. Macintosh HD⁩ ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Adobe⁩ ▸ ⁨Adobe Desktop Common⁩ ▸ ⁨HDBox⁩

Likes

Translate

Translate
LEGEND ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

Are you looking in the system library, not the user library?

 

If you click Go on the top menu and choose go to folder it usually takes you to /Library/ and you can follow the path from there. The helper app is usually inside the HDBox folder.

 

Macintosh HD⁩ ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Adobe⁩ ▸ ⁨Adobe Desktop Common⁩ ▸ ⁨HDBox⁩

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

LATEST

Thanks, I had automatically gone library >  Application Support > Adobe without checking which library it was (user or system).

 

When I follow the fix it now works.

 

Andy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines