Conversion from PSElements 2020 to PSElements 2021 failed

New Here ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

Problem: Cannot convert PhotoshopElements2020 Catalog to PhotoshopElements2021 - process says catalog is corrupt.

I tried "repair anyway" - still fails


Here's my situation:
I am attempting to move 47,000+ photos off an old HP Laptop running current Windows 10
- running PhotoshopElements 2020 with no problem
- PhotoshopElements catalog started with PhotoshopElements 3, then PhotoshopElements 5, 10, 13, 14, 15 and 2020
- all coversions up to and including PhotoshopElements 2020 went fine
- 2 external hard disks + internal drive hold the 47K+ photos

- Attempting to MOVE TO:

New HP Desktop (Win10) with 8gb internal drive, running PhotoshopElements2021/PremiereElements2021

(My first install of PhotoshopElements 2021 on the HP Desktop failed with a clean copy of photos - I ended up having to uninstall/reinstall PhotoshopElementslements/Premiere Elements 2021)

1) I copied the catalog from the laptop to the desktop, with the intent of reconnecting the files. I got the message the catalog was corrupt
2) I "repaired anyway", optimized", and rebuilt the index under PhotoshopElements2020 on the laptop, then copied the catalog to the desktop. I got the same message saying the catalog was corrupt.
3) I backed up the entire 47K photos in Elements2020 on the laptop, then did a restore onto the Desktop. All the files moved fine, but the conversion of the catalog failed with the same error message.
4) I clicked through all 47K+ photos on the laptop, making sure they all were connected to their source media. A few disconnects were removed.
- I optimized and "repaired anyway"
- I backed up PhotoshopElements2020 from the laptop which had zero disconnects, to an external hard disk, then turned off auto analyze and face analysis on Photoshop Elements 2021
5) I restored from that external hard disk to the internal drive on the new Desktop, running PhotoshopElements2021
- again, all of the photos and videos moved onto the HP internal drive with no apparent problems
- I get the same 'catalog is corrupt' error.


what now?

TOPICS
Import and export, Organizer, Problem or error

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation