Highlighted

Elements 13 upgraded to Elements 2019 but wont work on Catalina

New Here ,
Sep 07, 2020

Copy link to clipboard

Copied

Help.....please!

Originally I was running the package Elements & Premiere 13 on my Mac running High Sierra, I upgraded to 2019 which was working.

I subsequently upgraded my mac to a 2017 running Catalina, since I cannot get Elements or Premiere to run and when I try to run Organiser, its states it is not licenced.

I have tried to install 13 again however it says the installer needs to be updated 😞

I cannot think of any way to install 13 and then 2019, has anyone got any ideas please?

Thanking you all in anticpation,

Simon

TOPICS
Installation, New user

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Elements 13 upgraded to Elements 2019 but wont work on Catalina

New Here ,
Sep 07, 2020

Copy link to clipboard

Copied

Help.....please!

Originally I was running the package Elements & Premiere 13 on my Mac running High Sierra, I upgraded to 2019 which was working.

I subsequently upgraded my mac to a 2017 running Catalina, since I cannot get Elements or Premiere to run and when I try to run Organiser, its states it is not licenced.

I have tried to install 13 again however it says the installer needs to be updated 😞

I cannot think of any way to install 13 and then 2019, has anyone got any ideas please?

Thanking you all in anticpation,

Simon

TOPICS
Installation, New user

Views

33

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 07, 2020 0
Most Valuable Participant ,
Sep 07, 2020

Copy link to clipboard

Copied

Catalina is 64bit only, it will not run any program with 32bit components

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2020 1
Adobe Community Professional ,
Sep 07, 2020

Copy link to clipboard

Copied

The only version of Elements which will run on Catalina is 2020. All other versions include 32 bit components which will not run on Catalina.

 

There is no workaround other than downgrading from Catalina.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2020 1