Highlighted

Elements 15 has really started to act strangely

Community Beginner ,
Feb 13, 2019

Copy link to clipboard

Copied

Recently I have really begun to have a problem working in PSE 15.  Everything responds very slowly, if at all.  Tools take forever to perform their task.  I have done all the routine, i.e. leave and come back, reset tools, restart program, restart computer.  Nothing works.

Views

212

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Elements 15 has really started to act strangely

Community Beginner ,
Feb 13, 2019

Copy link to clipboard

Copied

Recently I have really begun to have a problem working in PSE 15.  Everything responds very slowly, if at all.  Tools take forever to perform their task.  I have done all the routine, i.e. leave and come back, reset tools, restart program, restart computer.  Nothing works.

Views

213

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 13, 2019 0
LEGEND ,
Feb 13, 2019

Copy link to clipboard

Copied

Are you using Windows or Mac? Which version?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Community Beginner ,
Feb 14, 2019

Copy link to clipboard

Copied

Sorry.  Really useful information....

Windows 10

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0
LEGEND ,
Feb 14, 2019

Copy link to clipboard

Copied

Try re-setting the prefs.

Launch the Editor and go to the menu:

Edit >> Preferences >> general (tab)

Click the button to re-set the preference settings on next launch

Close the editor and re-open

Let us know if that makes any improvement.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0
lesbraun LATEST
New Here ,
Feb 14, 2019

Copy link to clipboard

Copied

I have been having difficulty with getting Elements 15 downloading the Metadata along with the pictures.  Why is this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0