Highlighted

Elements 15 organiser slow on iMac running Sierra

New Here ,
Mar 01, 2017

Copy link to clipboard

Copied

I am a new iMac user. I recently bought Elements 15 from the app store. There were a few problems with a crashing editor, but that was solved with an upgrade. My problem is that the organiser is so slow it is unusable. I have about 2000 photos in my catalogue, but even selecting a photo takes ages. And now for the strange part: the editor is amazingly fast, especially compared to my old windows version! A batch conversion of raw files to jpg is at least 5 times faster. so not a general problem with Sierra or elements. Anyone else with this problem, or a solution?

Views

409

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Elements 15 organiser slow on iMac running Sierra

New Here ,
Mar 01, 2017

Copy link to clipboard

Copied

I am a new iMac user. I recently bought Elements 15 from the app store. There were a few problems with a crashing editor, but that was solved with an upgrade. My problem is that the organiser is so slow it is unusable. I have about 2000 photos in my catalogue, but even selecting a photo takes ages. And now for the strange part: the editor is amazingly fast, especially compared to my old windows version! A batch conversion of raw files to jpg is at least 5 times faster. so not a general problem with Sierra or elements. Anyone else with this problem, or a solution?

Views

410

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 01, 2017 0
Explorer ,
Apr 18, 2017

Copy link to clipboard

Copied

Try going into Preferences - Performance and unticking the graphics card option. It made all the difference for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2017 0
New Here ,
Feb 25, 2020

Copy link to clipboard

Copied

Batman:

 

New iMac w 24 Gb RAM, Safari 13.0, Mojave 10.13, PSE 2020 runs very slow, spinning ball on everything,

Allocated more than 15 Gb to PSE.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
New Here ,
Mar 02, 2020

Copy link to clipboard

Copied

I've found the problem; the previos version of PSE 15 was still installed, after using the PSE delete program, PSE 2020 is running the way it's supposed to.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2020 0