Highlighted

elements 20 on Mac

New Here ,
May 25, 2020

Copy link to clipboard

Copied

I have a Mac Catalina Version 10.15.4.  Elements 2020 is compatible with Version 10.15 - is that the same as 10.15.4?

Adobe Community Professional
Correct answer by John Waller | Adobe Community Professional

Yes. Elements is compatible with the 10.15 operating system including minor version updates: so 10.15.1, 10.15.2, 10.15.3, 10.15.4 and so on.

 

It's usually written in shorthand: 10.15.x which includes all minor version updates..

TOPICS
Mac

Views

362

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

elements 20 on Mac

New Here ,
May 25, 2020

Copy link to clipboard

Copied

I have a Mac Catalina Version 10.15.4.  Elements 2020 is compatible with Version 10.15 - is that the same as 10.15.4?

Adobe Community Professional
Correct answer by John Waller | Adobe Community Professional

Yes. Elements is compatible with the 10.15 operating system including minor version updates: so 10.15.1, 10.15.2, 10.15.3, 10.15.4 and so on.

 

It's usually written in shorthand: 10.15.x which includes all minor version updates..

TOPICS
Mac

Views

363

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 25, 2020 0
Adobe Community Professional ,
May 25, 2020

Copy link to clipboard

Copied

Yes. Elements is compatible with the 10.15 operating system including minor version updates: so 10.15.1, 10.15.2, 10.15.3, 10.15.4 and so on.

 

It's usually written in shorthand: 10.15.x which includes all minor version updates..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2020 1