Highlighted

Elements 2020 Organizer problems

Explorer ,
Oct 06, 2019

Copy link to clipboard

Copied

I have bought and downloaded Elements and Premiere 2020 as an upgrade, having used it since its inception.  There is a major problem now though.

For some reason the Organizer shows it stops at October 2018 wth about 104,000 photos, many are deleted files (!?) whereas my correct Organizer has 111,000 files and is up to date.  Fortunatley I can still open this, but its editor will still be PSE14.

So my question is how I do connect my correct Organizer to 2020 Elements and Premiere?  I am a professional photographer, so it is  important.  Thanks.

 

Views

490

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Elements 2020 Organizer problems

Explorer ,
Oct 06, 2019

Copy link to clipboard

Copied

I have bought and downloaded Elements and Premiere 2020 as an upgrade, having used it since its inception.  There is a major problem now though.

For some reason the Organizer shows it stops at October 2018 wth about 104,000 photos, many are deleted files (!?) whereas my correct Organizer has 111,000 files and is up to date.  Fortunatley I can still open this, but its editor will still be PSE14.

So my question is how I do connect my correct Organizer to 2020 Elements and Premiere?  I am a professional photographer, so it is  important.  Thanks.

 

Views

491

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 06, 2019 0
Adobe Community Professional ,
Oct 06, 2019

Copy link to clipboard

Copied

I am assuming that you upgraded from Elements 14 to 2020.  Did you use several catalogs in 14? Normally, when you install Elements, it will look for the most recently used catalog and convert that catalog to a new one that is compatible with the newer version.  It will also retain a backup that can be used in the older version.  If this is what happened to you, you can convert another catalog (your most up-to-date Elements 14 catalog) by going to the File>Manage Catalogs>Convert dialog.  There you will be able to search for your desired catalog and convert it for use in 2020. 

 

If you keep all of your catalogs in the default location, it should show up immediately in the Convert dialog.  If you are not sure where the catalog is, open it in Elements 14 and go to the Help>System Info. dialog.  It will notify you of the location of the open catalog.

 

Let us know if you are seeing something different than my explanation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2019 0
Explorer ,
Oct 06, 2019

Copy link to clipboard

Copied

Many thanks for your reply. I use Elements every day so understand it like the back of my hand, but I always have trouble trying to understand this sort of thing - files. Anyway, I followed it to ‘convert dialog’. It seems my Organizer is called pictures 1 1, but clicking ‘Convert’ has no effect, it has simply renamed it to My Catalog. This by the way shows Elements 13 so not too sure which it is. I have also tried to convert the Organizer that has been converted to 2020, the faulty one. I tried to convert this to the correct one but again it just keeps renaming it. I wonder if there is somewhere I could take my computer to, or phone perhaps. I reside in Bournemouth in the UK. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2019 0
Explorer ,
Oct 06, 2019

Copy link to clipboard

Copied

Many thanks for your reply. I use Elements every day so understand it like the back of my hand, but I always have trouble trying to understand this sort of thing - files. Anyway, I followed it to ‘convert dialog’. It seems my Organizer is called pictures 1 1, but clicking ‘Convert’ has no effect, it has simply renamed it to My Catalog. This by the way shows Elements 13 so not too sure which it is. I have also tried to convert the Organizer that has been converted to 2020, the faulty one. I tried to convert this to the correct one but again it just keeps renaming it. I wonder if there is somewhere I could take my computer to, or phone perhaps. I reside in Bournemouth in the UK. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2019 0
Adobe Community Professional ,
Oct 06, 2019

Copy link to clipboard

Copied

Ian said:

Anyway, I followed it to ‘convert dialog’. It seems my Organizer is called pictures 1 1, but clicking ‘Convert’ has no effect, it has simply renamed it to My Catalog.  This by the way shows Elements 13 so not too sure which it is.

Sorry, but I am not following you.  When Elements converts a catalog from one version to the next, it keeps the orginal catalog file name and makes a backup which is renamed with a suffix of 1.  The default catalog name is My Catalog.  If you haven't changed it, the new catalog will be named My Catalog and the backup which can still be opened in the earlier version will be named My Catalog 1.  It is possible to convert that older backup catalog again in a newer version.  The new backup will then be called My Catalog 1 1.  It looks to me that you have converted your catalog from 13 to 14 and now are converting to 2020.  Is that correct?

Ian said:

 I have also tried to convert the Organizer that has been converted to 2020, the faulty one. I tried to convert this to the correct one but again it just keeps renaming it.

I don't understand what you are doing.  A conversion makes a backup of the old catalog and creates a new catalog that can be opened in the newer program version.  The only renaming that takes place is adding a suffix to the original (backup) file.  Please answer my questions:

  1. Which versions of Elements have you had on your computer?
  2. What current versions do you have on your computer.
  3. Have you used multiple catalogs in any version of the program?  If so, what are the names you have given the catalogs.
  4. Have you changed the default location of the catalogs?  If so, where have you saved the catalog folders?  (This is done in the Catalog Manager).
  5. When you open your desired catalog (with 111,000 files) in Elements 14, what is the name it has?  The name can be viewed in the lower right corner of the status bar.  Alternatively, open the Catalog Manager and the name will be shown with [Current] at the end:

Snap10_2019.10.06_15h48m47s_001_.png

 

It would be helpful if you gave us screenshots of the main Catalog Manager screen (above) and also the dialog that opens when you click the Convert button.

Ian said:

I wonder if there is somewhere I could take my computer to, or phone perhaps. I reside in Bournemouth in the UK. Thanks.

My best friend from school in London has a holiday flat in Bournemouth and I have an open invitation to visit there.  But I currently reside in California.  So, I have no plans to hop over.  8)  If you answer my specific questions, I'm sure we can fix your problem online.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2019 0
Explorer ,
Oct 07, 2019

Copy link to clipboard

Copied

I will attempt to send the 2 screen prints pngs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2019 0
Explorer ,
Oct 07, 2019

Copy link to clipboard

Copied

I have clicked 'Convert' both on the 2020 Organizer and the correct up to date Organizer - which was not upgraded. It seems that I had Elements 13, 14 and 15 at some stage. I cannot see how to send a screenprint file with this. Also, is there a way I can come straight back to this instead of having to find my message each time?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2019 0
Adobe Community Professional ,
Oct 07, 2019

Copy link to clipboard

Copied

In order to post screenshots in the full forum editor screen, you need to click on the blue Reply button next to your original post. (A full editor also opens if you edit one of your grey posts.  This is a problem with the new forum and hopefully will be fixed.)  If you are receiving emails of posts in this thread, you should be able to click on the link in the email to take you back to this thread.  If you are not receiving emails, you can check a box that should appear below your reply before you post it.

 

Snap10_2019.10.07_12h14m31s_005_.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2019 0
Explorer ,
Oct 07, 2019

Copy link to clipboard

Copied

Thank you for trying, but I do seem to be having problems that never used to happen with this forum. I do not have the box you have illustrated anywhere on my messages, not the first, nor the last, or the grey, and nowhere to tick for replies. Emails do come through but I cannot get straight back to the forum ,nor my message. Strange that this seemed easier when using PSE4. Ian Julian Writer/Photographer www.natureandpictures.com Sunny Bournemouth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2019 0
Adobe Community Professional ,
Oct 08, 2019

Copy link to clipboard

Copied

Sorry if you are having trouble with the new forum here.  Most of us are.  Try this to post your screenshots:

Click on the Blue reply button next to your original post. 

 

Snap10_2019.10.08_00h58m14s_008_.png

 

When you do, the following post editing box should open:

 

Snap10_2019.10.08_00h59m04s_009_.png

Click on the third icon from the right to insert a photo/screenshot in your post.

 

If you have been clicking on the grey Reply button next to any reply posts in a thread, you should only see a one-line editor:

Snap10_2019.10.08_00h59m51s_010_.png

However, once you have posted a reply from this abbreviated editor, you can click on the More button and click Edit Reply and the larger editor will appear. 

Snap10_2019.10.08_01h00m58s_011_.png

 

This is a total mess and hopefully the forum will be fixed soon to avoid these problems.  If you are seeing something different than my screenshots, what browser are you using? 

As for following a link from your email to the thread in the forum, you must be signed in to the forum for the direct link to work.  If you have an automatic sign in, try linking from the email a second time, if you are not taken to this thread on your first try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0
Explorer ,
Oct 08, 2019

Copy link to clipboard

Copied

Thank you for that. However, it does not work. I press the blue button and do not get those choices, just 'Reply'. As I said, it seemed to work fine 15 years ago.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0
Greg_S. LATEST
Adobe Community Professional ,
Oct 08, 2019

Copy link to clipboard

Copied

It seems to me that you are not clicking on the blue Reply button at the top of the screen since you continue to post using a grey reply button.  Please go to the very top of the webpage where you posted your original question and click on the Blue button next to your post.  If you cannot reply there, it is because you are not sigined in to the forum.  The current forum only opened a few weeks ago.  If you still don't see the blue button after signing into the forum, what forum browser are you using?  If it isn't working, try another browser.  I am using Firefox.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0