Endless sign in loop in Photoshop Elements 2021

New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I am at my wits end.  I have had Adobe on my computer and so far they cannot correct the problem.  I purchased a software card for Photoshop Elements 2021 from Best Buy.  Thought I was purchasing software that I would install on my computer.......Never dreamed this is Adobe's way of controlling us by not letting us have software on our computer.  Anyway, I digress.  I installed, uninstalled, reinstalled a dozen times and so did they but nothing has stopped the endless sign in loop when trying to access the photo editor of Photoshop Element 2021.  Anyway have a fix that little ole me can do.  Other wise I wasted $100 and will NEVER use Adobe products again because this is ridiculous! 

TOPICS
Problem or error

Views

105

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

GO HERE AND CREATE AN ACCOUNT if you dont have one already.  

Adobe Account

set it up, login into it.   Then open the editor.

You're wasting time with all the uninstalls / reinstalls, please stop doing that. 

have you manually turned off any background processes, or have you run a utility that "stops unwanted programs"?



Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

I wasn't the one uninstalling and re-installing.  I had customer support on chat and for 3 different days, they have done that and nothing has worked.  I'm on satellite internet so it was taking 3 or 4 hours each install and they would leave and call the case closed.  So I would open and start another chat to let them know that the program was now installed and they could finish what they were doing but of coarse I got a new tech and they would do the same friggin thing again.  It happened again today!!!!  So I have asked to speak to a supervisor but they said they have to call !   I have 15 pages of transcripts that I copied from talking with these people who obviously don't know how to fix my problem.  

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Hi

 

Could you please confirm if your system date and time are correct and is in sync with the internet clock.

Please try to set the system date and time setting to Automatic and then try again to launch the Editor.

 

Also could you please confirm if you are being asked to Sign-in when installing the application?

 

Regards,

Vipin

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

System date and time are correct. The techs are the ones that have been installing the program.  It is still not working.  I have had ADOBE customer support on this problem since 02-21-21.  Fixing to escalate it to coorporate

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

After multiple days of dealing with ADOBE techs, I got one of our small laptops to see if it would install and run on it.  It did (but the laptop is too small to work from) so hence the problem is with my computer.  Guess I will work my wedding pics and senior pics from the old Photoshop Elements 13 which will work on my computer and then have my husband rebuild my computer.  He said that the serial number is probably stored in the windows directory, causing the error,  because it never ask me for the serial number. 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines