Help with some PSE18 and NIK plugin issues on W10?

Explorer ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Shooting mostly RAW. The RAW files are first viewed and culled in FastRawViewer. Next, a chosen image is sent to DxO PL4 Elite for initial processing, and then finished off in PSE 18 and PSE's NIK, if needs be.  BTW, I don't go directly from PL to its NIK because it just takes too long.  Once in PSE,  NIK opens much quicker. So, here are the problems:

1.  If PSE hasn't been opened yet, when it is called to open the file from PL, it opens with the NIK palette also opened.  I always want NIK to open with PSE.

2.  If PSE is already opened, when it is called to open the file fro PL, the NIK palette is not opened and has to be opened manually from either PSE File or PSE Filters. Why isn't NIK's palette opening under this condition?

3.  After finishing processing in PSE, saving it, and then closing the image from PSE, the opened NIK palette will close also. Why does the NIK palette close while PSE is still open and the processed image is closed?

4. When I go to File>Automation Tools>NIK Collection Selective Tools, nothing appears to happen.  Why isn't the NIK palette appearing?

I have the feeling that for #4, it may be the way that the NIK plugin is placed in the folder tree.  I'm not great at this, and if this be the case, I'd like to see how you guys place the plugin within the Folder.

Thanks.

TOPICS
Problem or error

Views

135

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Issue solved.

As I was sort of suspecting the way that the PSE 18 Plug-in tree was constructed, was at fault.  Luckily, I had the Plug-in tree correctly configured for PSE 14.  So, when I copied PSE 14's NIK plug-in folder and pasted it onto PSE 18 (after renaming PSE 18's plug-in folder so that it wouldn't be recognized by PSE 18,) all was well again: NIK palette was always available via File>Automated Tools, and the palette remained open after closing an edited image.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

Glad you got it sorted, and thanks for sharing the solution so other people can learn from it.

 

Any chance of a screenshot of your working plug-in folder structure? 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

Here's some screen shots. The first one is the one that works right. The second one, was the one that caused problems.  The problem was that I had too many references to NIK, like both the free NIK from Google and the free NIK from DxO.

 

NIK-3.jpgNIK-original.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

Thanks for the posting the screenshots 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Hate to say this, but although yesterday everything was working fine, today I'm back to he original questions....  Have no idea what happened to undo what I thought was a solution???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Would now appreciate seening the tree under Plugins for your PSE.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

I only have the free Nik Collection plug-ins obtained while Google held the license.  I just installed the collection from the exe file and it automatically loaded the plug-ins to all of the versions of Elements that I currently have loaded on my machine.  Here is a screenshot of my plugins folder structure for Elements 2018.  Each of the plug-in folders has  .8bf file(s) and a configuration file. 

Ashampoo_Snap_2021.04.15_11h48m08s_004_.png

All of the plug-ins are available from the Filters menu. The NIK palette also opens fine from the File>Automation Tools menu.

 

Ashampoo_Snap_2021.04.15_11h58m32s_005_.png

I assume that the current NIK version will be placed in a NIK folder instead of Google.

 

As for how the plug-in opens and closes in Elements, when first installed, the NIK palette automatically opens when  Elements is opened.  This option can be changed via the well-hidden settings menu.  I assume that the latest versions have something similar.

Ashampoo_Snap_2021.04.15_12h03m22s_000_SnapCollage.png

The only other comment I can make about your questions is that the NIK collection operates as both a standalone program and as an Elements plug-in.   When you are using Elements to edit a file, the plug-in version will open.  It will also close when you have completed editing with the plug-in.  I am guessing this is why you are seeing what you are seeing in your workflow.

 

Added:  I thought you were using PSE 2018.  There is an identical plug-ins folder for Elements 2020 (version 18).  (I have also unmarked your prior post as a correct answer.  Feel free to mark it as correct again.)

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

Actually, your post has settled the matter...sort of.  Here's why. I have the same Plug-ins tree as you do. And. this morning, when doing a test again, NIK remained after I closed the image I was working on...this is what I wanted.  However, after a little fooling aroud (I have several NIK folders and was trying to see which one worked the way I wanted it to,) NIK went bye-bye when the image was saved and closed but PSE remained open...not what I wanted.  Obviously, computer gremlins at work. But, then again, from your description, which I am now taking as the way I can expect NIK to work...closes when image is closed, I'll just live with it. Thanks for you effort and clarification of the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

Although I apparently gave up on my quest to keep the NIK palette within the PSE screen after closing an image, I guess I didn't as I now think I have solved the issue.  Yes, the palette goes south when one closed the image via the "x" that is in the upper left corner; however, if the image is closed from the Phot Bin (right click>close,) then the palette stays on board. Hope I'm right?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 17, 2021 Apr 17, 2021

Copy link to clipboard

Copied

LATEST

This is nuts! Obviously, there are bugs in the Google NIK. Thought things were solved, but Nooo.  There are times when closing an image, the palette stays, and then thre are time when the palette closes.  There are times when NIK will open from File>Automated Tools, and times when it won't. However, NIK is alway present and working from Filters??? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines